View Issue Details

IDProjectCategoryView StatusLast Update
0001669unrealircdpublic2004-03-18 21:21
Reportersyzop Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0001669: Spamfilter remove problem/strange behavior
DescriptionFor some reason nobody reported it here, so I don't know if it's a widespread/big problem or something...

1 user reported that a /spamfilter del.. thingy only worked on 1 server and not on all others.

Today I experienced a similar issue on a net... I did /spamfilter del... and then ANOTHER rule (the wrong one!) got removed.. very strange.. They didn't even have similar text or something.
Steps To ReproduceUnknown yet / in process
Additional InformationPerhaps related to local rules ('f'), or backward-compatible (RC1 'F'z) spamfilters... no idea yet.
TagsNo tags attached.
3rd party modules



2004-03-18 17:49

administrator   ~0005528

will look at it in the next few days (prolly tomorrow, perhaps this night) :)


2004-03-18 18:46

reporter   ~0005531

i had a problem that in an older cvs that whenever the set ban-reason in ircd config wasnt just spaces instead of _ and u added a spamfilter regex in real time with underscores...the new spamfilter got screwed up on a remote server.duno if this is related....nor if the reasons in spamfilter.config should use underscores instead of spaces as in the current cvs de set-ban-reason doesnt need to be underscored....
Ok i shut up now before i really confuse ppl with what im trying to say ...:P


2004-03-18 18:57

reporter   ~0005532

and now in cvs 2185 without using underscores..just spaces in the set-ban-reason in the ircd.conf.

i added /spamfilter add cp gline 3d spamming_is_lame

but on remote server it shows as:

spamming__is__lame (double underscores......perhaps related with your bug?


2004-03-18 19:04

administrator   ~0005533

don't think it's related (the __ stuff is only on recent cvs I think), but that still looks like another bug ;p


2004-03-18 19:06

reporter   ~0005534

ok i was able to reproduce YOUR bug also...did a spamfilter del and it indeed removed an other luckily its a test server :P....good luck in fiding the bug


2004-03-18 20:44

administrator   ~0005539

ah good... question for you then: is this just 1 server, or a network? and is this (/are they all) RC2? :)


2004-03-18 21:07

administrator   ~0005540

found I think


2004-03-18 21:21

administrator   ~0005541

Fixed in CVS (.2189), was RC2 specific (RC1 is unaffected).

Issue History

Date Modified Username Field Change
2004-03-18 17:42 syzop New Issue
2004-03-18 17:49 syzop Note Added: 0005528
2004-03-18 18:46 Fury Note Added: 0005531
2004-03-18 18:57 Fury Note Added: 0005532
2004-03-18 19:04 syzop Note Added: 0005533
2004-03-18 19:06 Fury Note Added: 0005534
2004-03-18 20:44 syzop Note Added: 0005539
2004-03-18 21:07 syzop Note Added: 0005540
2004-03-18 21:21 syzop Status new => resolved
2004-03-18 21:21 syzop Resolution open => fixed
2004-03-18 21:21 syzop Assigned To => syzop
2004-03-18 21:21 syzop Note Added: 0005541