View Issue Details

IDProjectCategoryView StatusLast Update
0001704unrealircdpublic2005-02-27 17:34
ReporterpakAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformvariousOSvariousOS Versionvarious
Product Version3.2-RC2 
Target VersionFixed in Version3.2.3 
Summary0001704: operoveride bug
DescriptionAn oper with the oper override flag, cannot deop a chmode +a or +q user when the oper is a channel operator, they can however if they deop themselves
Steps To Reproduceattempt to deop a +a or +q user when oped in the channel
TagsNo tags attached.
3rd party modules

Activities

thunderbirdjl

2004-04-07 08:46

reporter   ~0005757

Last edited: 2004-04-07 08:46

Agreed. An oper with the operoverride flag who is +o cannot deop -o someone who is +a or +q. They can however deadmin and/or deowner them -a/-q.

Also, a halfop with operoverride cannot deadmin and/or deowner and/or deop a +q or +a.

edited on: 2004-04-07 08:46

vonitsanet

2004-04-12 07:07

reporter   ~0005830

Yes that's true..
And something else.. Only network administrators can set (+q -q) (+a -a) modes on a channel. Services Admins, Server Admins, IrcOps, etc with operoverride flag can not set these modes.

syzop

2004-04-13 16:26

administrator   ~0005851

Unfortunately the mode code prevents us from fixing this without causing a desynch... I've fixed it that it accepts it from remote servers for now so if the bug is fixed in the future (3.2.1? cvs about a month?) it will all go fine.
In that case we could also look into the a/q netadmin only stuff (which looks like a leftover "feature" from before we had can_override).

I know people tend to disagree on whether we should support mixed-versions-networks but we left the beta stage and I don't feel it's a good idea to cause a desynch right now.

pak

2004-04-17 06:42

reporter   ~0005875

I presume this comes under the same problem, and can't be fixed without a desync, but an oper with voice or halfops in a channel cannot oper override to invite users

syzop

2005-02-27 17:34

administrator   ~0009334

Fixed in .300 -- feel free to test.

Issue History

Date Modified Username Field Change
2004-04-06 18:35 pak New Issue
2004-04-07 08:46 thunderbirdjl Note Added: 0005757
2004-04-07 08:46 thunderbirdjl Note Edited: 0005757
2004-04-12 07:07 vonitsanet Note Added: 0005830
2004-04-13 16:26 syzop Note Added: 0005851
2004-04-17 06:42 pak Note Added: 0005875
2005-02-27 17:34 syzop Status new => resolved
2005-02-27 17:34 syzop Fixed in Version => 3.2.3
2005-02-27 17:34 syzop Resolution open => fixed
2005-02-27 17:34 syzop Assigned To => syzop
2005-02-27 17:34 syzop Note Added: 0009334