View Issue Details

IDProjectCategoryView StatusLast Update
0001926unrealdocumentationpublic2004-10-13 18:38
ReporterhypnetricAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSWindowsOS VersionXP Professional
Product Version3.2.1 
Target VersionFixed in Version3.2.2 
Summary0001926: mkpasswd documentation
Description***** Mkpasswd *****
 -
 This command will Encrypt the string it has been given
 So you can add it directly to the unrealircd.conf if you use
 Encrypted passwords. Type can be crypt, sha1, or md5. Sha1
 and md5 are only available when compiled with SSL support.
 -
 Syntax: MKPASSWD <method> <password>
 Example: MKPASSWD crypt mpsare
 -

The bug is that MD5 and SHA1 work on a non-SSL compile, atleast for WIN32.
TagsNo tags attached.
3rd party modules

Activities

syzop

2004-07-06 21:21

administrator   ~0006907

Nice summary line.

Zell

2004-07-06 21:57

reporter   ~0006908

yesh, I use both Linux and Win32 versions and I have the same results. All formats of the mkpasswd command are available. Except, I have, in the past, had trouble with the "crypt" method.... but It seems that problem is fixed in the later releases (3.2 betas and above).

codemastr

2004-07-06 23:47

reporter   ~0006915

First off, USE A TITLE THAT MAKES SENSE. Saying "read this" makes me read it last. It doesn't make me want to fix the problem, it makes me want to ignore it. If you can't even take the time to write out an appropriate title, why should we take the time to look into it? A title of "read this" doesn't help us. It gives us NO indication about what the problem is, or if there is even a problem at all.

Syzop, now that we include MD5, do you think it would be a smart idea to simply use that code to make MD5 always available? MD5 is a nice alternative to have for systems that would normally only have crypt. Plus, since the Win32 code for MD5 is rather crazy, I'm sure using our own routine would be faster as well. Another thing I notice is that the documentation doesn't even mention ripemd160.

syzop

2004-07-07 08:51

administrator   ~0006920

*nod*
Yeah, I was working on that (always-md5-support@*NIX) when I was making passwords-with-a-salt. Plus, I was also cleaning the code a bit up so not everything is in 1 big routine heh ;p. (I however stopped working on this a few weeks ago, but I'm sure when I feel like it I'll start working on it again! :P).

master-control-program

2004-09-05 10:22

reporter   ~0007538

I will admit that I'm by no means a programmer, however I am thurough in everything I do.

Regarding the md5 encryption :
Every web resource I have checked seems to be all the same versions. And the $md5 algo in mIRC returns the same values, and I tried 2 freeware programs that convert plain text into md5 and they all return the same values for what I give them. All except the UnrealIRCD that is. No matter what I try I can't get md5 to work. In addition when I use the MKPASSWD command, the text I get back is way different from what I got from mIRC and the freeware programs, and every other web resource I used. Are there different versions of md5 I am not aware of?

I can account for the fact that I did not enable SSL, and I'm plenty hazy on how to really use SSL and encryption and so on, so I tried as many combinations as I had patience for :

putting the encrypted pass in the CONF, useing quotes on the pass in the CONF and in the encrypted password, etc... just to name a few.

The documentation is a little strange in that for adding the auth-type there are no quotes "", but with no auth-type there are quotes "" around the password. Are there supposed to be quotes around the password when specifying the auth type?

If you guys have the patience to help me understand I'd most appreciate it. Thanks :)

master-control-program

2004-09-05 10:24

reporter   ~0007539

when I say auth-type I was referring to the DRPASS block, sorry for that mistake.

aquanight

2004-09-05 16:27

reporter   ~0007540

>Every web resource I have checked seems to be all the same versions. And the $md5
>algo in mIRC returns the same values, and I tried 2 freeware programs that
>convert plain text into md5 and they all return the same values for what I give
>them. All except the UnrealIRCD that is. No matter what I try I can't get md5 to
>work. In addition when I use the MKPASSWD command, the text I get back is way
>different from what I got from mIRC and the freeware programs, and every other
>web resource I used. Are there different versions of md5 I am not aware of?

Unreal encodes the MD5 hash using Base64.

syzop

2004-10-13 18:38

administrator   ~0007999

MKPASSWD in help.conf is now a bit more clear regarding encryption (actually, hash) types in .154.

Issue History

Date Modified Username Field Change
2004-07-06 19:46 hypnetric New Issue
2004-07-06 21:21 syzop Note Added: 0006907
2004-07-06 21:57 Zell Note Added: 0006908
2004-07-06 23:43 codemastr Summary Read this, thanks. => mkpasswd documentation
2004-07-06 23:47 codemastr Note Added: 0006915
2004-07-07 08:51 syzop Note Added: 0006920
2004-09-05 10:22 master-control-program Note Added: 0007538
2004-09-05 10:24 master-control-program Note Added: 0007539
2004-09-05 16:27 aquanight Note Added: 0007540
2004-10-13 18:38 syzop Status new => resolved
2004-10-13 18:38 syzop Fixed in Version => 3.2.2
2004-10-13 18:38 syzop Resolution open => fixed
2004-10-13 18:38 syzop Assigned To => syzop
2004-10-13 18:38 syzop Note Added: 0007999