View Issue Details

IDProjectCategoryView StatusLast Update
0002020unrealircdpublic2004-09-04 04:24
ReportercrazyAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.1 
Target VersionFixed in Version3.2.2 
Summary0002020: Channel mode +M bug ?
DescriptionThe docs and /helpop say :
M = Must be using a registered nick (+r) to talk [o]
all non registered user can talk in a +M channels if they have +v/h/o/a/q ....

blabla is crazytoon@FuNNy-Chat-C15A86F1.pool.mediaways.net * crazytoon
blabla is using modes +ix
......

[04:03:05] * Now talking in #M_test
[04:04:23] * crazy sets mode: +M
[04:04:41] <blabla> test
#M_test You must have a registered nick (+r) to talk on this channel (#M_test)
[04:05:00] * crazy sets mode: +v blabla
[04:05:05] <+blabla> test
[04:05:27] * crazy sets mode: -v+h blabla blabla
[04:05:33] <%blabla> test
[04:06:15] * crazy sets mode: -h+o blabla blabla
[04:06:20] <@blabla> test
[04:06:36] * crazy sets mode: -o+a blabla blabla
[04:06:44] <&blabla> test
[04:07:15] * crazy sets mode: -a blabla
[04:07:20] <blabla> test
#M_test You must have a registered nick (+r) to talk on this channel (#M_test)

I thought a user need +r (registered) to talk and not Chmodes like +v ??
TagsNo tags attached.
3rd party modules

Activities

aquanight

2004-08-13 03:10

reporter   ~0007348

Well. +v means "can speak". No Ifs, Ands, or Buts. Since +a > +o > +h > +v, what +v overrides +hoaq overrides.

Rocko

2004-08-13 12:12

reporter   ~0007349

This isn't a valid bug, it works fine here.
Maybe your nick blabla wasn't registered or/and hasn't the usermode +r set.

avone

2004-08-13 18:03

reporter   ~0007350

Last edited: 2004-08-13 18:11

tested it. You can speak without having usermode +r when having any channel mode +v or higher as the original poster reported.

edited on: 2004-08-13 18:11

medice

2004-08-14 10:55

reporter   ~0007352

i'd say: either set +M or throw around with +v to any people you don't know - it's within the channel-ops' decision
i know it's becoming popular to +v any user joining a channel, but I still can't understand this idea at all (especially channels with bots setting +v to everyone, or (on networks with services) Chanserv (or equals) giving +v to everyone)

sence of voice was to allow a certain users (mostly single users) to speak on +m channels and not as today most popular to put everyone a funky cool "+" prefix on his face ;)

crazy

2004-08-15 15:18

reporter   ~0007369

>(on networks with services) Chanserv (or equals) giving +v to everyone)

Not all services.Anope Chanserv(services bots) giv only +r user +v on autovioce (eg : autovoice level 0) Channels.But that is not the point...

1.The description in the Docs/helpop ist wrong and confuse the user..It´s say :

M = Must be using a registered nick (+r) to talk [o]

and not:

M = Must be using a registered nick (+r) to talk [o](only +vhoaq NOT registered users may talk)

>"i know it's becoming popular to +v any user joining a channel, but I still can't understand this idea at all (especially channels with bots setting +v to everyone... "

Maybe because the channel-op / owner read the /HELPOP CHMODES ;=) and he saw a possibility to set autovoice on the channel (with eggdrop mabye) but only +r user can speak... eg: chmode +mM...

2.For what is +M to be good?? ( only for stop -v not registered user talk?. this doesn't make sense to me ) I think the Idea is to stop clone/spam bots to?? or not ? That would have a sense...
You want stop user talk on channels do chmod +m it´s work to...

aquanight

2004-08-15 17:32

reporter   ~0007371

>M = Must be using a registered nick (+r) to talk [o](only +vhoaq NOT registered users may talk)

Just for the sake of making that make sense, why not:

M = Must be a registered nick (usermode +r) or voiced (channelmode +v) to talk [o]

I'm guessing the deal here is that +M is a form of flood control. For example, if you have unregistered bots join and start textflooding, you'd +v all the unregistered innocent users, and set +NM, then start banning bots. Or you could +v all the innocent normals, and set +Nm (then it'd be easier to identify the bots ;p ). (And for the bots that joinpart-flood, you'd probably use +R or +i instead.)

yodaone

2004-08-15 20:58

reporter   ~0007372

There is no need to say +M stops everyone talking except +qaohv because +v says the user can talk regardless of any modes (bmM etc)

codemastr

2004-08-16 03:50

reporter   ~0007373

I agree, I think this is more a documentation error than anything else. Think of the problems this could cause:

You're +q, the owner of the channel.
You change your nick to "me-away", services sets you -r as a result.
You can't talk until you change your nickname back and you identify.

All I see is problems, I don't see how changing this would make +M better. If somehow making +v NOT override +M makes it work better, please explain how since I don't see it.

medice

2004-08-16 09:02

reporter   ~0007375

I'd suggest to make the documentation more clear and point out that +vhoaq overrides +M since +M's function is perfectly fullfilled the way it is right now.

I understand +M as a special variant of +m (something handy between +m and +R in fact...) - if users have +v they may speak in +m -channels so it seems logical and reasonable to do the same on +M.

Rocko

2004-08-16 13:45

reporter   ~0007376

'You're +q, the owner of the channel.
'You change your nick to "me-away", services sets you -r as a result.
'You can't talk until you change your nickname back and you identify.

Uhm, thats wrong, you can talk when you have +q and +M is set.
You can't talk when you have NOT +qaohv and are unregistered ;)

codemastr

2004-09-04 04:24

reporter   ~0007501

As of .127 the text now reads:

M = Must be using a registered nick (+r), or have voice access to talk [o]

Issue History

Date Modified Username Field Change
2004-08-13 02:21 crazy New Issue
2004-08-13 03:10 aquanight Note Added: 0007348
2004-08-13 12:12 Rocko Note Added: 0007349
2004-08-13 18:03 avone Note Added: 0007350
2004-08-13 18:06 avone Note Edited: 0007350
2004-08-13 18:11 avone Note Edited: 0007350
2004-08-14 10:55 medice Note Added: 0007352
2004-08-15 15:18 crazy Note Added: 0007369
2004-08-15 17:32 aquanight Note Added: 0007371
2004-08-15 20:58 yodaone Note Added: 0007372
2004-08-16 03:50 codemastr Note Added: 0007373
2004-08-16 09:02 medice Note Added: 0007375
2004-08-16 13:45 Rocko Note Added: 0007376
2004-09-04 04:24 codemastr Status new => resolved
2004-09-04 04:24 codemastr Fixed in Version => 3.2.2
2004-09-04 04:24 codemastr Resolution open => fixed
2004-09-04 04:24 codemastr Assigned To => codemastr
2004-09-04 04:24 codemastr Note Added: 0007501