View Issue Details

IDProjectCategoryView StatusLast Update
0002045unrealircdpublic2004-09-03 23:51
ReporterheperAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformunixOSlinux 2.4.22OS Versionredhat
Product Version3.2.1 
Target VersionFixed in Version3.2.2 
Summary0002045: ip ban (channels) impossible when users ip has resolved to some.isps.host
Descriptionimpossible to set an ip in a channel when user's ip has resolved on connect
if the users ip doesnt resolve on connect then the ip ban works.
So if you whois a user and it shows something ident@ip then ip channel bans work ... if ya whois a user and it shows ident@host then you cant channel ban its IP

I think it has NOTHING todo with the +x mode
Steps To ReproduceSTEP1:
connect to any unreal 3.2.1 ircd using a not-resolvable host
(whois info shows somethin like "connecting from 192.168.0.1 192.168.0.1)
STEP2:
try to ban it from any channel using /mode #channel +b *@ip (ex: /mode #channel +b *@192.168.0.1)
then you will see the ban works.

STEP3:
connect to any unreal 3.2.1 ircd using a resolvable host (ex: set reverse dns for 192.168.0.2 to testhost.testdomain)
STEP4:
then try to ban it from any channel using /mode #channel +b *@ip (ex: /mode #channel +b *@192.168.0.2)
you will then notice that the ban DOES NOT work

Additional Informationhttp://www.phpmemx.net/~unrealir/forums/viewtopic.php?t=798
TagsNo tags attached.
3rd party modules

Activities

al5001

2004-08-29 17:26

reporter   ~0007454

Yeah, I also notice the same thing with /who, it will not work with IP addresses except for unresolved ones.

codemastr

2004-08-29 17:58

reporter   ~0007456

al5001, well it's not supposed to. Unless you are talking about /who +i ?

al5001

2004-08-29 18:20

reporter   ~0007457

Last edited: 2004-08-29 18:21

Ah, sorry. I never seen the +i option. I always used +h and could never figure out why it would never list the users with the IP. Is it possible to combine +i and +h? 'Cause when you mentioned +i, I had never seen that option before.

So it's not a bug, it's just not used for +h. My bad.

edited on: 2004-08-29 18:21

AngryWolf

2004-09-02 14:38

reporter   ~0007475

Uhm, well, a quote from section "3.13 - Ban types" of unreal32docs.html:

"IP bans are also available (eg: *!*@128.*) and are also always checked."

No mention about +i.

al5001

2004-09-03 03:57

reporter   ~0007478

Last edited: 2004-09-03 04:12

Ok... let's not get /who mixed up with bans.

+i was an option in /who: eg: /who +i 192.168.*

(Unfortunately there is no mention about /who flags in the documentation, but it is in the help.conf file provided with every version of Unreal3.2)


From what this reporter has told us, I have tested it myself.

lightning.chattingaway.com WHOIS pomme
:lightning.chattingaway.com 311 pomme pomme ipfw ca-CF0C7BCB.nt.net * :deny ip from any to any
:lightning.chattingaway.com 378 pomme pomme :is connecting from *@Timmins6-167.nt.net 209.226.88.167
:lightning.chattingaway.com 307 pomme pomme :is a registered nick
:lightning.chattingaway.com 319 pomme pomme :@#test #lobby
:lightning.chattingaway.com 312 pomme pomme lightning.chattingaway.com :ChattingAway
:lightning.chattingaway.com 317 pomme pomme 11603 1094172735 :seconds idle, signon time
:lightning.chattingaway.com 318 pomme pomme :End of /WHOIS list.

Now I'll join #test and ban *!*@209.226.88.167.

lightning.chattingaway.com join #test
:pomme!ipfw@ca-CF0C7BCB.nt.net JOIN :#test
lightning.chattingaway.com MODE #test
:lightning.chattingaway.com 353 pomme = #test :pomme ip6fw
:lightning.chattingaway.com 366 pomme #test :End of /NAMES list.
:lightning.chattingaway.com 324 pomme #test +
:lightning.chattingaway.com 329 pomme #test 1094184082
lightning.chattingaway.com MODE #test +b *!*@209.226.88.167
:pomme!ipfw@ca-CF0C7BCB.nt.net MODE #test +b *!*@209.226.88.167

Alright, here's the fun part. I'll connect a clone and join the channel.

:ip6fw!ipfw@ca-CF0C7BCB.nt.net JOIN :#test

Hmm... ok let's see if this person's IP is that of the one that's banned.

lightning.chattingaway.com whois ip6fw
:lightning.chattingaway.com 311 pomme ip6fw ipfw ca-CF0C7BCB.nt.net * :deny ip from any to any
:lightning.chattingaway.com 319 pomme ip6fw :#test
:lightning.chattingaway.com 312 pomme ip6fw lightning.chattingaway.com :ChattingAway
:lightning.chattingaway.com 317 pomme ip6fw 657 1094184103 :seconds idle, signon time
:lightning.chattingaway.com 318 pomme ip6fw :End of /WHOIS list.

Bingo. Ok, so this user is correct, if an IP resolves to a host, an IP ban on that user does not work.

edited on: 2004-09-03 04:12

codemastr

2004-09-03 20:15

reporter   ~0007483

I haven't looked at it yet, but it sounds like it is not using GetIp though it should be.

codemastr

2004-09-03 23:51

reporter   ~0007486

Fixed in .123

Issue History

Date Modified Username Field Change
2004-08-28 13:49 heper New Issue
2004-08-29 17:26 al5001 Note Added: 0007454
2004-08-29 17:58 codemastr Note Added: 0007456
2004-08-29 18:20 al5001 Note Added: 0007457
2004-08-29 18:21 al5001 Note Edited: 0007457
2004-09-02 14:38 AngryWolf Note Added: 0007475
2004-09-03 03:57 al5001 Note Added: 0007478
2004-09-03 04:12 al5001 Note Edited: 0007478
2004-09-03 20:15 codemastr Note Added: 0007483
2004-09-03 23:51 codemastr Status new => resolved
2004-09-03 23:51 codemastr Fixed in Version => 3.2.2
2004-09-03 23:51 codemastr Resolution open => fixed
2004-09-03 23:51 codemastr Assigned To => codemastr
2004-09-03 23:51 codemastr Note Added: 0007486