View Issue Details

IDProjectCategoryView StatusLast Update
0002083unrealircdpublic2005-08-28 12:58
ReporterWhite_MagicAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.1 
Target VersionFixed in Version3.2.4 
Summary0002083: SpamFilter Problem
Description*** F c gzline 0 34659 86400 Spam/Advertising libra-away!happy@ircop.icq.com <joni33e> i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f :uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you??

added onto the spamfilter however it wont come off,
tryed to use the del and remove command - no error msgs are given but it isnt removed either.

Additional InformationThe remove command doesnt have an example in the Unrealircd Documents.
TagsNo tags attached.
3rd party modulesnone

Activities

aquanight

2004-09-20 19:45

reporter   ~0007744

well I would've tried to use the {count} repeat qualifiers to make that shorter... because I'm guessing you're overstepping some limit here...

Unfortunately, there's no easy to way to wipe the spamfilter list... rmtkl doesn't support it (yet) otherwise, I'd suggest use that to get rid of it.

So the only other way is restart or something...

White_Magic

2004-10-09 18:53

reporter   ~0007933

coders any ideas / tests on this ????

codemastr

2004-10-10 00:00

reporter   ~0007936

What did you type to remove it?

White_Magic

2004-10-10 03:27

reporter   ~0007940

/spamfilter del c gzline - -<joni33e> i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f :uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you??

/spamfilter remove c gzline - -<joni33e> i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f :uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you??

/spamfilter remove c gzline - - <joni33e> i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f :uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you??

are the commonds tryed to use to remove it

White_Magic

2004-10-23 12:29

reporter   ~0008090

?¿?¿?

avone

2004-10-23 19:10

reporter   ~0008091

do a /stats f and paste us the raw output of what it says for that particular spamfilter

syzop

2004-10-23 19:48

administrator   ~0008094

Try removing the ':' from the text, so:
/spamfilter remove c gzline - - <joni33e> i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you?? i own you and you are mine i own you and you are mine i own you and i can f uck you??

If that still didn't help, then perhaps the text was just too long.

aquanight

2004-10-23 21:19

reporter   ~0008095

I think it was suggested some time ago to implement number-based removing for spamfilters. I'm beginning to agree, as long spamfilters can be difficult to remove such as in this case... though I would go with something easy to track, like md5+base64 the regex, and return it in the list, like after the setter field and then I just do /spamfilter [del|remove|-]md5 <the md5> and that spamfilter is removed. Would make insanely long spamfilters like this easier to remove :) .

w00t

2004-10-24 07:43

reporter   ~0008098

Yes. One thing I hate about removing spamfilters is that, and then the fact that you have to know the options (cp, etc) that it was added with. I mean... uhhhhh..?

Stealth

2004-10-24 21:24

reporter   ~0008104

I would like to be able to remove a spamfilter but just using:

/spamfilter -regex

And that will remove all spamfilters with the specified regex.

White_Magic

2004-10-25 15:37

reporter   ~0008109

well its gone now, (after a restart) the it dispappeared so pft to treying to solve it unless someone else wants to add the it and try it themselfs, sorry :|

syzop

2004-10-26 10:25

administrator   ~0008118

Bugz: unfortunately that isn't possible due to the way the commands system works. If you have a 'long parameter' (meaning: multiple words that should be a param, in our case the regex), you cannot have a variable number of arguments (unless you force clients to use ':').
Anyway, "/spamfilter remove - - - - <regex>" would be possible.
But I wonder how much of "added value" that would be :PP.

The (md5) hash idea of aquanight is interresting however, would have to think about that [post-3.2.2 obviously].

syzop

2005-08-26 19:22

administrator   ~0010397

*bump*

JasonTik

2005-08-27 11:59

reporter   ~0010398

That same system could be used with RegExp: /spamfilter delregex ^RegExp? +here\.$

White_Magic

2005-08-28 05:51

reporter   ~0010401

hmm, i think this is a version thing, coz i tryed the regex in 3.2.3 and it added and removed it easily,
regradless of the fact it had a : inside it..

syzop

2005-08-28 12:58

administrator   ~0010403

Last edited: 2005-08-28 12:59

This should now be fixed in CVS [.375].

Changelog:
- Spamfilter: regexes (and reasons) are now more limited in size, this is to combat "I set
  a spamfilter, but cannot remove it" problems. In practice this means - depending on the
  length of your spamfilter reason - regexes will be max ~300 characters.
  Spamfilters set in the .conf can be slightly longer (which still causes them to be
  truncated in '/stats f', but they don't have to be removed anyway so it's kinda
  acceptable if it's really needed). This should fix bug 0002083, reported by White_Magic.


Issue History

Date Modified Username Field Change
2004-09-20 17:12 White_Magic New Issue
2004-09-20 17:12 White_Magic 3rd party modules => none
2004-09-20 19:45 aquanight Note Added: 0007744
2004-10-09 18:53 White_Magic Note Added: 0007933
2004-10-10 00:00 codemastr Note Added: 0007936
2004-10-10 03:27 White_Magic Note Added: 0007940
2004-10-23 12:29 White_Magic Note Added: 0008090
2004-10-23 19:10 avone Note Added: 0008091
2004-10-23 19:48 syzop Note Added: 0008094
2004-10-23 21:19 aquanight Note Added: 0008095
2004-10-24 07:43 w00t Note Added: 0008098
2004-10-24 21:24 Stealth Note Added: 0008104
2004-10-25 15:37 White_Magic Note Added: 0008109
2004-10-26 10:25 syzop Note Added: 0008118
2005-08-26 19:22 syzop Note Added: 0010397
2005-08-27 11:59 JasonTik Note Added: 0010398
2005-08-28 05:51 White_Magic Note Added: 0010401
2005-08-28 12:58 syzop Status new => resolved
2005-08-28 12:58 syzop Fixed in Version => 3.2.4
2005-08-28 12:58 syzop Resolution open => fixed
2005-08-28 12:58 syzop Assigned To => syzop
2005-08-28 12:58 syzop Note Added: 0010403
2005-08-28 12:59 syzop Note Edited: 0010403