View Issue Details

IDProjectCategoryView StatusLast Update
0002096unrealircdpublic2004-11-13 12:25
ReporterWhite_MagicAssigned Tocodemastr 
PrioritynormalSeveritytrivialReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002096: Who flag for bots
Descriptioni went to do some eggy work and wanted to find all the bots in a 200 + people channel, i was almost certain the /who system had a flag to find " bots " only but it seems it dont - this would be useful for opers /chanops to find bots with +B umode.
TagsNo tags attached.
3rd party modules

Activities

syzop

2004-09-27 23:11

administrator   ~0007810

/who +m B

White_Magic

2004-09-27 23:59

reporter   ~0007811

duh i know there was a way, thanks syzop - im off to bed now *hangs head in shame lol*

aquanight

2004-09-28 01:55

reporter   ~0007812

I should point out that only works for IRCops...

White_Magic

2004-10-18 08:18

reporter   ~0008035

-> irc-m08.icq.aol.com WHO +m B
<- :irc-m08.icq.aol.com 315 Desolator +m :End of /WHO list.

-> irc-m08.icq.aol.com WHO +m B #Exotica
<- :irc-m08.icq.aol.com 315 Desolator +m :End of /WHO list.

/who #Exoctica +m B - just returns a normal /who #Exotica

the channel is full of bots as well,

DefuckinMented is MeNtAL@115C9317.2FACC459.559BA39.IP * chingAlingLING
DefuckinMented is a registered nick
DefuckinMented on @#Scottish %#phoe @#Bitch-X @#CitY_ChaT @#novkortera ^#forsaken @#exotica
DefuckinMented using irc-m08.icq.aol.com IrCQnet
DefuckinMented is a Bot on IrCQnet
DefuckinMented has been idle 40hrs 43mins 6secs, signed on Sat Oct 16 20:08:24
DefuckinMented End of /WHOIS list.

Dickdiggler is wh0rebag@9208D73E.2FACC459.559BA39.IP * Its gettin hot in here
Dickdiggler is a registered nick
Dickdiggler on @#Scottish @#Bitch-X %#phoe @#CitY_ChaT @#novkortera @#forsaken @#exotica
Dickdiggler using irc-m05.icq.aol.com IrCQnet
Dickdiggler is a Bot on IrCQnet
Dickdiggler End of /WHOIS list.
-
Bella is pip@F4DF5297.ECFAB7AE.559BA39.IP * Blacklight
Bella is a registered nick
Bella on @#colombia @#exotica %#phoe @#novkortera
Bella using irc-m08.icq.aol.com IrCQnet
Bella is a Bot on IrCQnet
Bella End of /WHOIS list.

how come i cant make it work for a channel - im presumming /who +m B requires ircop but....

aquanight

2004-10-18 11:32

reporter   ~0008036

/who +cm #Exoctica B

White_Magic

2004-10-18 11:54

reporter   ~0008037

-> irc-m08.icq.aol.com WHO +cm #Exotica B
<- :irc-m08.icq.aol.com 315 Desolator +cm :End of /WHO list.

codemastr

2004-10-19 17:16

reporter   ~0008043

I'm not quite sure I understand the problem...

White_Magic

2004-10-21 11:16

reporter   ~0008056

the orginal problem was a way to dectect is anyone have umode +B set, but Syzop showed me the /who covered that, the problem NOW is, im not an ircop i am +q in 10 channels whihc contain eggy drop bots with umode +B and i cannot make /who return *only bots* to me, using the following commands have failed..

WHO +m B
WHO +m B #Exotica
WHO #Exoctica +m B

i tryed Aquanights suggestion which was
WHO +cm #Exotica B
 this also failed, how do i make it work?????

aquanight

2004-10-22 00:30

reporter   ~0008060

I can't seem to reproduce the problem...

codemastr

2004-10-22 15:22

reporter   ~0008061

[quote]im not an ircop[/quote]
Well that's why. As aquanight already said, you *must* be an IRCOp. +q is irrelevant, that doesn't make you an IRCOp. The /who +m B flag will not work unless you are an oper. So I don't see a bug here...

White_Magic

2004-10-22 15:40

reporter   ~0008063

Shouldnt it work for Ops thou if it involes +c ?

aquanight

2004-10-22 15:42

reporter   ~0008064

Flag m <usermodes>: user has <usermodes> set, **********ONLY o/C/A/a/N FOR NONOPERS**********


ChanOP != Oper :P

White_Magic

2004-10-22 15:44

reporter   ~0008065

/who +c for channel!

aquanight

2004-10-22 15:57

reporter   ~0008066

So you're saying a user who is normally not allowed to see usermodes should be able to get them through an alternative method?

syzop

2004-10-22 16:01

administrator   ~0008067

dumdeedum...
Only reason I left this bug open is so there could be some discussion about letting users do +m B, since basically they already can see who is a bot and who isn't (via whois). [note that stuff like +/-m does not suddenly allow the user to view MORE users than with normal '/who', rather.. it restricts the output]

White_Magic

2004-10-22 16:21

reporter   ~0008068

my reply to aquanight is, no not allow them as such but since ops are required to run a channel, i feel they should have the ablity to use the /who to see who has *which* conditions in the channel there in, for example whos bots, whos away, whose here, whos idle for or more than X time?((?) if its possible)
etc

aquanight

2004-10-22 16:39

reporter   ~0008069

syzop: By that logic there'd be a few other modes to enable as well. +z and +h to name two. Since users can probably tell who's using a hidden host by whois, maybe let them do x too, though this could be a bad idea since it could give nasty people a way to find non-invisible, ip-wide-open users to "play with", but who doesn't set::modes-on-connect "+ix" and set::restrict-user-modes "ix" ? :P (Actually, I don't, but still...)

Stealth

2004-10-22 17:04

reporter   ~0008070

Maybe this should be something returned by /who as a flag, instead of a command flag.

A new flag such as "B" would do, and clients can be scripted to only return the users with this flag.

codemastr

2004-10-29 15:13

reporter   ~0008174

I kind of like both ideas. Allow +B searching, and also show a B in the flags.

Stealth

2004-10-29 17:33

reporter   ~0008178

Both ideas would be great if implimented.

syzop

2004-10-29 17:35

administrator   ~0008179

Last edited: 2004-10-29 17:36

codemastr: how are you gonna deal with breaking numerics then?
(I'm sure you have some idea about it ;p)

edited on: 2004-10-29 17:36

codemastr

2004-10-29 22:13

reporter   ~0008181

I don't see how this would break any numerics?

syzop

2004-11-07 10:38

administrator   ~0008262

hm? Odd.. I thought I had posted a comment here.
Anyway, ignore that breaking-numerics-statement.. I misunderstood the proposed idea.

codemastr

2004-11-13 12:25

reporter   ~0008302

Added in .181

Issue History

Date Modified Username Field Change
2004-09-27 23:09 White_Magic New Issue
2004-09-27 23:11 syzop Note Added: 0007810
2004-09-27 23:59 White_Magic Note Added: 0007811
2004-09-28 01:55 aquanight Note Added: 0007812
2004-10-18 08:18 White_Magic Note Added: 0008035
2004-10-18 11:32 aquanight Note Added: 0008036
2004-10-18 11:54 White_Magic Note Added: 0008037
2004-10-19 17:16 codemastr Note Added: 0008043
2004-10-21 11:16 White_Magic Note Added: 0008056
2004-10-22 00:30 aquanight Note Added: 0008060
2004-10-22 15:22 codemastr Note Added: 0008061
2004-10-22 15:40 White_Magic Note Added: 0008063
2004-10-22 15:42 aquanight Note Added: 0008064
2004-10-22 15:44 White_Magic Note Added: 0008065
2004-10-22 15:57 aquanight Note Added: 0008066
2004-10-22 16:01 syzop Note Added: 0008067
2004-10-22 16:21 White_Magic Note Added: 0008068
2004-10-22 16:39 aquanight Note Added: 0008069
2004-10-22 17:04 Stealth Note Added: 0008070
2004-10-29 15:13 codemastr Note Added: 0008174
2004-10-29 17:33 Stealth Note Added: 0008178
2004-10-29 17:35 syzop Note Added: 0008179
2004-10-29 17:36 syzop Note Edited: 0008179
2004-10-29 22:13 codemastr Note Added: 0008181
2004-11-07 10:38 syzop Note Added: 0008262
2004-11-09 15:46 codemastr Status new => assigned
2004-11-09 15:46 codemastr Assigned To => codemastr
2004-11-09 15:47 codemastr Summary new who flag => Who flag for bots
2004-11-13 12:25 codemastr Status assigned => resolved
2004-11-13 12:25 codemastr Fixed in Version => 3.2.3
2004-11-13 12:25 codemastr Resolution open => fixed
2004-11-13 12:25 codemastr Note Added: 0008302