View Issue Details

IDProjectCategoryView StatusLast Update
0002097unrealircdpublic2004-09-29 16:49
ReporterurkelAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSFreeBSDOS VersionAll
Product Version3.2.1 
Target VersionFixed in Version3.2.2 
Summary0002097: Hostname Resolving With FreeBSD Jails
DescriptionHostname resolving doesn't work in FreeBSD Jails, because unrealircd binds to *:UDPport for its own resolving. On a FreeBSD Jail System all services must bind to the specific IP address of the jail. So, jail_ip:UDPport.
Additional InformationBahamut IRCd had the same problem but it could be solved using the attached patch. Would be great if you can do the same with unrealircd.
TagsNo tags attached.
3rd party modules

Activities

2004-09-29 09:10

 

res.c.diff (647 bytes)

syzop

2004-09-29 14:10

administrator   ~0007820

when I read the patch it seems it's more like the problem is that we DON'T bind, and your patch adds binding to INADDR_ANY (which I guess will be translated to a specific ip in freebsd jail?). Fun :P

I don't think this patch will cause any problems in a non-jail environment, so I guess we should add it.

Thanks.

syzop

2004-09-29 16:49

administrator   ~0007822

Thanks, added in CVS [.144].
Works perfectly / exactly how I thought.

Issue History

Date Modified Username Field Change
2004-09-29 09:10 urkel New Issue
2004-09-29 09:10 urkel File Added: res.c.diff
2004-09-29 14:10 syzop Note Added: 0007820
2004-09-29 16:42 syzop Assigned To => syzop
2004-09-29 16:42 syzop Status new => assigned
2004-09-29 16:49 syzop Status assigned => resolved
2004-09-29 16:49 syzop Fixed in Version => 3.2.2
2004-09-29 16:49 syzop Resolution open => fixed
2004-09-29 16:49 syzop Note Added: 0007822