View Issue Details

IDProjectCategoryView StatusLast Update
0002121unrealircdpublic2004-10-29 14:35
ReporterWhite_MagicAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002121: WATCH webtv support
Description[13:10] <Name141> [07:11:39:am] -> *IRC* WATCH +COWMOO
[13:10] <Name141> -----
[13:10] <Name141> [07:11:45:am] * Connecting to someirc (+6668)
[13:10] <Name141> -----
[13:10] <Name141> * Your nickname is now COWMOO
[13:10] <Name141> -----
[13:12] <Name141> didn't do shit

Additional InformationSeems when myself added a nickname to the watch list, the server didnt return any kind of message to say that the operation was sucussful, and when i typed the
/msg irc WATCH commaond - it didnt return the list of users i had ment to of added to my watch list.

this is all listed in the helpop but isnt working at all.
TagsNo tags attached.
3rd party modules

Activities

crazy

2004-10-11 13:08

reporter   ~0007957

Its work fine :P I think you are using Mirc+Script ... Is a Mirc_Script error because is missing the raw nummerics for WATCH .... Look at this page to see a example WATCH script :p

http://trout.snt.utwente.nl/ubbthreads/showflat.php?Cat=&Board=developerforum&Number=10851&page=21&view=collapsed&sb=5&o=&fpart=1

syzop

2004-10-11 15:28

administrator   ~0007959

[17:28:13] * Test sets mode: +i
[17:28:14] -> *irc* watch +Test2
Test2 * * 0 is offline
[17:28:22] * Your nick is now Test2
Test2 none syzop.hoklan 1097508500 logged online

Works fine. Same for 'WATCH' or /msg irc watch.

Now if you mean that webtv users don't see anything, then that's a different issue.. because as you know webtv is crap and doesn't display (most) numerics :P.

White_Magic

2004-10-11 16:45

reporter   ~0007961

thats interesting that mirc doesnt process it... i was under the impression irc would notice / message the user saying <nickname> is online..

anyway to make it work for webbies?

syzop

2004-10-11 17:24

administrator   ~0007962

@mirc: Well, as you can see it works fine. Also mIRC does use WATCH internally (or ISON if WATCH isn't available) for the notify list... I hope you have heard of that, since it's a pretty known feature *g* ;).

codemastr

2004-10-11 18:00

reporter   ~0007964

Well, we do have umode +V. Making the watch notification check whether the user is +V wouldn't be too hard. It basically loops through the list of "watchers" and does a sendto_one. So we could make it send a PRIVMSG if the user is +V, rather than sending a numeric.

Syzop: any objections?

syzop

2004-10-11 18:11

administrator   ~0007965

Sure, if you want to do it.. it looks ok to me.

codemastr

2004-10-29 14:35

reporter   ~0008173

Added in .167

Issue History

Date Modified Username Field Change
2004-10-11 12:21 White_Magic New Issue
2004-10-11 13:08 crazy Note Added: 0007957
2004-10-11 15:28 syzop Note Added: 0007959
2004-10-11 16:45 White_Magic Note Added: 0007961
2004-10-11 17:24 syzop Note Added: 0007962
2004-10-11 18:00 codemastr Note Added: 0007964
2004-10-11 18:11 syzop Note Added: 0007965
2004-10-28 10:21 syzop Summary WATCH command doesnt work(?) => WATCH webtv support
2004-10-28 15:52 codemastr Status new => assigned
2004-10-28 15:52 codemastr Assigned To => codemastr
2004-10-29 14:35 codemastr Status assigned => resolved
2004-10-29 14:35 codemastr Fixed in Version => 3.2.3
2004-10-29 14:35 codemastr Resolution open => fixed
2004-10-29 14:35 codemastr Note Added: 0008173