View Issue Details

IDProjectCategoryView StatusLast Update
0002126unrealircdpublic2004-11-05 15:37
Reporterbrain2Assigned Tocodemastr 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002126: non-fatal warnings for duplicate config tags
DescriptionFeature request:

when duplicate tags are found in the config file, currently no action is taken. The last tag to be found overrides the first, for example oper-only-stats which is supposed to only occur once, may be entered into the set {} block multiple times.

I propose a *non-fatal* warning message on startup (to console or the logs) which warns the user of duplicate tags, and also some way to disable the warning either with a parameter to ircd or at compile time.
TagsNo tags attached.
3rd party modules

Activities

codemastr

2004-10-14 23:34

reporter   ~0008014

To be honest, I was considering something like this recently. After 3.2.2 is released, I intend to rewrite a bunch of the config handling code and one of the things this rewrite will do is make such things easier. For the set block, it will still be a bit difficult (since the multiple set blocks are merged together) but I think it is doable. I'd just want to make sure the additional checks necessary do not impact performance by too much.

codemastr

2004-11-03 15:50

reporter   ~0008243

Added in .170

Issue History

Date Modified Username Field Change
2004-10-14 22:25 brain2 New Issue
2004-10-14 23:34 codemastr Note Added: 0008014
2004-10-29 15:23 codemastr Status new => assigned
2004-10-29 15:23 codemastr Assigned To => codemastr
2004-11-03 15:50 codemastr Status assigned => resolved
2004-11-03 15:50 codemastr Resolution open => fixed
2004-11-03 15:50 codemastr Note Added: 0008243
2004-11-05 15:37 codemastr Fixed in Version => 3.2.3