View Issue Details

IDProjectCategoryView StatusLast Update
0002145unrealinstallingpublic2004-11-06 12:42
ReporterStealthAssigned Tocodemastr 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002145: More ./Config options
DescriptionI would like to see more options in ./Config, then I dont need to remember to edit any files to set/unset options.

The ones I am mainly interested in, and others might find useful are (from config.h):

LIST_SHOW_MODES
SHUN_NOTICES
NO_OPEROVERRIDE
OPEROVERRIDE_VERIFY
NAZIISH_CHBAN_HANDLING (hmmm... says its undef, but still does the ban thing...)
DISABLE_USERMOD
TagsNo tags attached.
3rd party modules

Activities

JasonTik

2004-10-28 23:37

reporter   ~0008162

Last edited: 2004-10-28 23:39

I like it, However, I would like to add another config option. Dont know what it was exactly, but it made it so only netadmins could see +s in /list

EDIT:
SHOW_SECRET
ty Stealth

edited on: 2004-10-28 23:39

codemastr

2004-10-28 23:51

reporter   ~0008163

Well the thing is, we want to try and keep the ./Config setting as basic as possible. For example, the NAZIISH_CHBAN_HANDLING would likely confuse people. Hence why it is hidden from most people.

Stealth

2004-10-28 23:54

reporter   ~0008164

I am curretnly wondering why NAZIISH_CHBAN_HANDLING still seems to be enabled even though it says its undef... Unless I have a broken understanding of undef...

syzop

2004-10-29 08:50

administrator   ~0008166

/me agrees with codemastr
There are >10 other options you could move to ./Config then, I too think it should just keep with the basics (so like we have now) and keep include/config.h for the less-frequently-used options / finetuning.

codemastr

2004-10-29 14:20

reporter   ~0008171

Maybe we could "kinda" add it? Like ./Config -advanced or something?

syzop

2004-10-29 14:30

administrator   ~0008172

Hm, good idea.

Issue History

Date Modified Username Field Change
2004-10-28 23:28 Stealth New Issue
2004-10-28 23:37 JasonTik Note Added: 0008162
2004-10-28 23:39 JasonTik Note Edited: 0008162
2004-10-28 23:51 codemastr Note Added: 0008163
2004-10-28 23:54 Stealth Note Added: 0008164
2004-10-29 08:50 syzop Note Added: 0008166
2004-10-29 14:20 codemastr Note Added: 0008171
2004-10-29 14:30 syzop Note Added: 0008172
2004-10-29 15:04 codemastr Status new => assigned
2004-10-29 15:04 codemastr Assigned To => codemastr
2004-11-06 12:42 codemastr Status assigned => resolved
2004-11-06 12:42 codemastr Fixed in Version => 3.2.3
2004-11-06 12:42 codemastr Resolution open => fixed