View Issue Details

IDProjectCategoryView StatusLast Update
0002188unrealircdpublic2004-11-19 15:24
Reporterdiskman1Assigned Tocodemastr 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version-
Product Version3.2.3 
Target VersionFixed in Version3.2.3 
Summary0002188: in deny link {} in rules with "-" in the mask config fails
Descriptioni want to add an deny link {} block
 with
deny link {
mask server1.myirc.net;
rule "directcon(server2.myirc.net)";
type auto;
};

it works fine

with

deny link {
mask server1.my-irc.net;
rule "directcon(server2.myirc.net)";
type auto;
};

it works fine too
but *g*
with

deny link {
mask server1.myirc.net;
rule "directcon(server2.my-irc.net)";
type auto;
};

i got these error:

[19:19:18] *** (s) Rehash- Reloading IRCd configuration (by diskman)
[19:19:33] *** (s) Notice -- Loading IRCd configuration ..
[19:19:33] *** (s) Notice -- error: tmp/8D539AEB.deny.conf:49: deny::rule contains an invalid expression: Unknown token
[19:19:33] *** (s) Notice -- error: 1 errors encountered
[19:19:33] *** (s) Notice -- error: IRCd configuration failed to pass testing

config file is in tmp because im using remote includes
TagsNo tags attached.
3rd party modules

Activities

crazy

2004-11-17 15:35

reporter   ~0008360

Last edited: 2004-11-17 15:38

I can reproduce it (also without remote includes)


-anaconda.xxxxxxxx.net- *** Notice -- Loading IRCd configuration ..
-
-anaconda.xxxxxxxx.net- *** Notice -- error: unrealircd.conf:432: deny::rule contains an invalid expression: Unknown token
-
-anaconda.xxxxxxx.net- *** Notice -- error: 1 errors encountered
-
-anaconda.xxxxxxxx.net- *** Notice -- error: IRCd configuration failed to pass testing

*edit* on Unreal3.2.2 1.1.1.1.2.18 :P

codemastr

2004-11-17 15:40

reporter   ~0008361

It sounds like it is treating - as a separator, which it should not be doing. I'll look into it.

diskman1

2004-11-19 02:29

reporter   ~0008366

hmm anyone has any idea how i can use deny link {} for servers with - in servername ?
any wildcards in crule allowed?
thanks for help

2004-11-19 15:22

 

crule.diff (1,035 bytes)

codemastr

2004-11-19 15:23

reporter   ~0008375

Fixed in .187. I also uploaded a patch (crule.diff) that will solve the problem for you.

Issue History

Date Modified Username Field Change
2004-11-17 13:29 diskman1 New Issue
2004-11-17 15:35 crazy Note Added: 0008360
2004-11-17 15:38 crazy Note Edited: 0008360
2004-11-17 15:40 codemastr Note Added: 0008361
2004-11-17 15:40 codemastr Status new => acknowledged
2004-11-19 02:29 diskman1 Note Added: 0008366
2004-11-19 15:22 codemastr File Added: crule.diff
2004-11-19 15:23 codemastr Status acknowledged => resolved
2004-11-19 15:23 codemastr Fixed in Version => 3.2.3
2004-11-19 15:23 codemastr Resolution open => fixed
2004-11-19 15:23 codemastr Assigned To => codemastr
2004-11-19 15:23 codemastr Note Added: 0008375
2004-11-19 15:23 codemastr Assigned To codemastr =>
2004-11-19 15:24 codemastr Assigned To => codemastr