View Issue Details

IDProjectCategoryView StatusLast Update
0002190unrealircdpublic2004-11-25 14:26
ReportersacAssigned Tocodemastr 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002190: /invite list
DescriptionIf we have +si channels in the irc and we invite users to join the channels, these channels still don't show in /list method.

It migth be desirable (at least for me it was) having several +si channels and a bot inviting allowed people to them.

I send you a patch with the implemented feature. If you find it useful you may consider merging.

Thanks for your great work...
TagsNo tags attached.
3rd party modules

Activities

2004-11-19 11:28

 

listaCanalesSecretos.txt (1,430 bytes)

codemastr

2004-11-19 14:44

reporter   ~0008370

Ok, first off, your method of checking invites is bad. You want to search through the user's list of invites, not the channel. The channel list of invites will likely be longer than the list for the particular user, therefore it is more efficient to use the user's list. Second, I have no idea what is up with all of your crazy double pointers. None of that is necessary and is in fact wasteful (memory references take time).

But finally, you say it's useful, but you don't say why. First, why are there users who are invited but don't join? That usually means they did not want the invite which means they don't care if it is in /list. So why exactly is this useful to you? Whenever I'm going to add something that will impact performance, I'd like a reason first.

aquanight

2004-11-19 17:32

reporter   ~0008382

Last edited: 2004-11-19 17:34

Well, for example, I have my client's "auto-join on invite" feature disabled (I hate that feature anyway blah :P ). If I'm away and I'm waiting get invited to some channels I normally go on and then something happens (like massive server notices or something) and the invite message(s) get(s) scrolled off the scrollback, how am I going to know what channel(s) I was invited to (especially w/o server window logging)? If I did /list and then saw, hello, why is there a +si channel that I'm not in and I'm not +o? Must've been invited... :) *join* . Anyway, I'd probably think it's better just to have clients have a command to get a list of all the channels they've been invited to that they haven't joined yet. And of course, this is why unreal can do modules... :P

codemastr

2004-11-19 22:48

reporter   ~0008383

Well yeah, you can come up with a scenario like that, but I mean, how often does that happen in real life? Let me put it this way. You're on a 50,000 user network. Are you going to do a /list and get 10,000 results just so you can see the 2 +si channels you have been invited to but have not joined? I doubt it.

As for a command to list the invites, that's not a bad idea. Perhaps the best way to do something like that would be something like /invite with no parameters lists your active invites?

Stealth

2004-11-19 23:39

reporter   ~0008384

I like the command idea, and yes, I think having /invite with no parameters would be an ideal thing to have rather than making a new command for it.

While we are on the topic of invite, maybe impliment a way for opers to see the invites of a channel. I think that would be useful for seeing if channels are mass-inviting to get more users.

sac

2004-11-22 07:24

reporter   ~0008386

The thing is that I am building an intranet chat server with reduced clients and many restrictions in the ways normal client can interoperate with the server.
aquanight has described the situation very well, i should have been more descriptive, sorry about that...
You are right, the double pointers are a mess, because i copied the del_invite function just changing the "if" body and i didn't realize that the client's list will likely be shorter that the channel one. sorry about that too , i am starting to crawl right now.

I liked list command to do that because most of the clients have an interface that uses "/list" to show channels.

Maybe a good solution could be looking for secret channels in user invite list after the main list has been sent in send_list. If we find any, send it too, and we could even do it without calling the ShowChannel macro to save time.

sorry for the inconveniences... i just wanted to help...

codemastr

2004-11-25 14:26

reporter   ~0008411

Typing /invite now lists all the channels you are invited to, but have yet to join. Added in CVS .192

Issue History

Date Modified Username Field Change
2004-11-19 11:28 sac New Issue
2004-11-19 11:28 sac File Added: listaCanalesSecretos.txt
2004-11-19 14:44 codemastr Note Added: 0008370
2004-11-19 17:32 aquanight Note Added: 0008382
2004-11-19 17:34 aquanight Note Edited: 0008382
2004-11-19 22:48 codemastr Note Added: 0008383
2004-11-19 23:39 Stealth Note Added: 0008384
2004-11-22 07:24 sac Note Added: 0008386
2004-11-25 00:44 codemastr Summary LIST command should list secret channel when user is invited into it? => /invite list
2004-11-25 00:44 codemastr Status new => assigned
2004-11-25 00:44 codemastr Assigned To => codemastr
2004-11-25 14:26 codemastr Status assigned => resolved
2004-11-25 14:26 codemastr Fixed in Version => 3.2.3
2004-11-25 14:26 codemastr Resolution open => fixed
2004-11-25 14:26 codemastr Note Added: 0008411