View Issue Details

IDProjectCategoryView StatusLast Update
0002199unrealircdpublic2015-07-19 18:50
ReportereggburtAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.2 
Target VersionFixed in Version3.4-beta1 
Summary0002199: tkl update doesn't actually update
DescriptionWhen a k/gline is set (haven't test any others) and then re-set with a time lower than the time it already is it doesn't actually update the removal time
(note: it was a real ip, has been censored)

command: /gline QuikSilvr come back with brains
*** Permanent G:Line added for *@xx.xx.xx.xx on Sat Nov 27 20:14:45 2004 GMT (from eggburt!mr-bob@eggburt.MikerNet: back with brains)

forgot the time, making it perm, so had to change
command: /gline *@xx.xx.xx.xx 300 come back with brains (5mins)
tkl update for *@xx.xx.xx.xx/reason='come back with brains (5mins)'/by=eggburt!mr-bob@eggburt.MikerNet/set=1101586485/expire=0 [causedby: themiker.ny.us.mikernet.org]

a while later (I forgot about it)
command: /gline
G *@xx.xx.xx.xx 0 2130 eggburt!mr-bob@eggburt.MikerNet come back with brains (5mins)
Steps To Reproducek/gline an address
k/gline it again (without removing) with a lower time than the origional
wait
Additional InformationApologies if this has already been reported (couldn't find it if it was)
TagsNo tags attached.
3rd party modules

Activities

eggburt

2004-11-27 16:23

reporter   ~0008421

oh yeah, happened on all OSs I tested, so I didn't put that in

in the example the version was 3.2.1, but I tested on a 3.2.2 server and it happened the same

syzop

2004-11-27 17:16

administrator   ~0008422

hm tkl update is misleading in this context, the 'tkl update' stuff is ment for server<->server synching.. not modifying-an-existing-TKL-by-a-user.

syzop

2004-11-30 19:00

administrator   ~0008445

acknowledged as a possible feature to be added.

syzop

2015-07-19 18:49

administrator   ~0018528

I just tried this and it does update now, both updating expiry time and the reason worked. Don't know when this was fixed exactly.

Issue History

Date Modified Username Field Change
2004-11-27 16:20 eggburt New Issue
2004-11-27 16:23 eggburt Note Added: 0008421
2004-11-27 17:16 syzop Note Added: 0008422
2004-11-30 19:00 syzop Note Added: 0008445
2004-11-30 19:00 syzop Status new => acknowledged
2015-07-19 18:49 syzop Note Added: 0018528
2015-07-19 18:49 syzop Status acknowledged => resolved
2015-07-19 18:49 syzop Fixed in Version => 3.4-beta1
2015-07-19 18:49 syzop Resolution open => fixed
2015-07-19 18:49 syzop Assigned To => syzop