View Issue Details

IDProjectCategoryView StatusLast Update
0002212unrealircdpublic2004-12-02 22:45
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002212: make most eyes snomask messages global
DescriptionJust an idea I came up with...
it would be nice if opernotices like Oper Override would be broadcasted since these are usually quite informative/might be important to know (like for ethical reasons and stuff).

I don't intend to make ALL eyes snomasks global, but like these:
- OperOverride (invite, kick, mode, topic)
- CHG*
Dunnow (tending towards 'no'):
- forbidden channel join (deny channel::warn on)
Most likely not:
- /mkpasswd, /stats usage
- TS bounce, TS fix
TagsNo tags attached.
3rd party modules

Activities

codemastr

2004-12-02 21:15

reporter   ~0008459

Yeah I agree with the ones you chose.

syzop

2004-12-02 22:04

administrator   ~0008460

Last edited: 2004-12-02 22:04

aw.. stupid me.. CHG* stuff were already "global" due to CHG* stuff being send to all servers, and of the override messages also all were global but not the INVITE stuff (which seems quite crucial to me ;p).. So all I had to do is change that one (well ok, like 6 calls).

I've also added sendto_snomask_global() which works just like sendto_snomask(), changed a call in src/modules/m_oper.c to use the new one when I was at it :).

[will commit in a while]

syzop

2004-12-02 22:44

administrator   ~0008461

Done in .205

Issue History

Date Modified Username Field Change
2004-12-02 19:41 syzop New Issue
2004-12-02 21:15 codemastr Note Added: 0008459
2004-12-02 22:04 syzop Note Added: 0008460
2004-12-02 22:04 syzop Note Edited: 0008460
2004-12-02 22:44 syzop View Status private => public
2004-12-02 22:44 syzop Note Added: 0008461
2004-12-02 22:44 syzop Status new => resolved
2004-12-02 22:44 syzop Fixed in Version => 3.2.3
2004-12-02 22:44 syzop Resolution open => fixed
2004-12-02 22:44 syzop Assigned To => syzop
2004-12-02 22:44 syzop Assigned To syzop =>
2004-12-02 22:45 syzop Assigned To => syzop