View Issue Details

IDProjectCategoryView StatusLast Update
0002228unrealircdpublic2004-12-09 12:28
ReporterzEkEsTeRAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS VersionUnknown
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002228: except tkl not working
DescriptionThe file "tklexcept.conf" is included from unrealircd.conf, but its contents (all except tkl {}'s, and a couple of except ban {}'s, are not being implemented.
Steps To ReproduceSee above
TagsNo tags attached.
3rd party modules

Activities

syzop

2004-12-08 12:44

administrator   ~0008554

Hmmm.. thought you ment dup of 0000585, sorry...
Ehm they don't have any effect? I've never heard of that problem.
Are you sure the include stuff (or part of the contents of the included file itself) isn't commented out?
Also make sure there are no config warnings.

To doublecheck if a certain directive is not commented out, you can do something like changin:
include "tklexcept.conf";
into:
SDFIGHFSFDG;
or something similar ;P

codemastr

2004-12-08 14:56

reporter   ~0008555

Yeah it sounds kind of strange to me. the same function that loads the main unrealircd.conf also loads the include files (recursive calls). Therefore, it is executing the *exact* same code.

zEkEsTeR

2004-12-08 21:01

reporter   ~0008556

Just double checked all comments and so on.
I can see no obvious reason they wouldn't be included, none of it is commented, errors occur when things in that file are incorrect, but the except blocks arent' taking effect, and aren't showing in any of the appropriate /stats listings.

Also, the IRCd version reply is 3.2.2, but I believe its 3.2.2-CVS

zEkEsTeR

2004-12-08 21:04

reporter   ~0008557

ARGH forgot to include ReleaseID - sorry :)

[14:56:24] --- Birth Date: Sun Dec 5 2004 at 20:49:48 EST, compile # 3
[14:56:24] --- On-line since Sun Dec 5 21:22:41 2004
[14:56:24] --- ReleaseID (1.1.1.1.2.1.2.1.2.2234.2.207 2004/12/03 22:00:07)
[14:56:24] --- End of /INFO list.

syzop

2004-12-08 23:38

administrator   ~0008558

Well, in that case.. could you attach your unrealircd.conf and the-included-conf to this bugreport? Feel free to remove/change sensitivy info like passwords, cloak-keys and stuff.
(attach them to this bugreport, do not post urls, since someone just infiltrated, waaah)

zEkEsTeR

2004-12-09 00:35

reporter   ~0008561

Removed all the oper blocks and most of the listen lines as that server is p'worded and supposed to be pretty hidden.

syzop

2004-12-09 12:22

administrator   ~0008562

confirmed @ CVS, I'm afraid this is yet another config rewrite bug :/

syzop

2004-12-09 12:28

administrator   ~0008563

Fixed in .208.
[oh eh, just for the record, this only affects post-3.2.2 CVS]

Issue History

Date Modified Username Field Change
2004-12-08 02:00 zEkEsTeR New Issue
2004-12-08 12:40 syzop Relationship added duplicate of 0000585
2004-12-08 12:41 syzop Relationship deleted 0000585
2004-12-08 12:44 syzop Note Added: 0008554
2004-12-08 14:56 codemastr Note Added: 0008555
2004-12-08 21:01 zEkEsTeR Note Added: 0008556
2004-12-08 21:04 zEkEsTeR Note Added: 0008557
2004-12-08 23:38 syzop Note Added: 0008558
2004-12-08 23:38 syzop View Status public => private
2004-12-09 00:33 zEkEsTeR File Added: unrealircd.conf
2004-12-09 00:34 zEkEsTeR File Added: tklexcept.conf
2004-12-09 00:35 zEkEsTeR Note Added: 0008561
2004-12-09 12:22 syzop Note Added: 0008562
2004-12-09 12:22 syzop Assigned To => syzop
2004-12-09 12:22 syzop Status new => assigned
2004-12-09 12:24 syzop File Deleted: unrealircd.conf
2004-12-09 12:24 syzop File Deleted: tklexcept.conf
2004-12-09 12:26 syzop Severity minor => major
2004-12-09 12:26 syzop Reproducibility have not tried => always
2004-12-09 12:26 syzop Build => CVS (post-3.2.2)
2004-12-09 12:26 syzop View Status private => public
2004-12-09 12:26 syzop Summary except blocks aren't included in include "";'s => except tkl not working
2004-12-09 12:28 syzop Status assigned => resolved
2004-12-09 12:28 syzop Fixed in Version => 3.2.3
2004-12-09 12:28 syzop Resolution open => fixed
2004-12-09 12:28 syzop Note Added: 0008563