View Issue Details

IDProjectCategoryView StatusLast Update
0002230unrealircdpublic2004-12-10 15:22
ReporterGSF19Assigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSfreebsdOS Version
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002230: flat-map option returnes juped servers also
Descriptionjust what the summary says.. if you turn flat-map option on it returnes also juped servers.. something that normally shouldnt happen.. i hope i'm not missing something otherwise this is a bug.
TagsNo tags attached.
3rd party modules

Activities

aquanight

2004-12-09 20:20

reporter   ~0008568

Last edited: 2004-12-09 20:21

And what are "juped servers"? Nothing more than servers introduced behind services, for the sole purpose that if the real server tried to connect, it'd get dropped due to server collision. In fact, a server can be juped based on name AND numeric this way. The only thing is: Unreal doesn't know the difference :P . So how, in fact why, should it hide juped servers, except maybe in the case of hide-ulines (because servers and users behind a ulined server are themselves ulined...)

GSF19

2004-12-09 20:39

reporter   ~0008569

Last edited: 2004-12-09 20:39

okay then.. since unrealircd knows that the juped server comes behind a ulined server like services.. and when in normal mode it hides the juped server.. then the "how" question could be answered.. thats the reason that hide-ulines exist :P it hides only the ulined server and not the server behind it.

codemastr

2004-12-09 22:35

reporter   ~0008571

I couldn't quite tell from your post, is hide-ulines enabled? If not, then no, they would not be hidden. If it is enabled, then it would seem to be a bug.

syzop

2004-12-09 23:29

administrator   ~0008573

I was thinking, are servers behind u-lines actually u-lined too? I know users are, but servers? (if they are, perhaps double check that it gets set?)
That the juped servers where hidden in a non-flat-map was probably just because that branch was hidden/stopped when it found your u-lined services server.
Just a theory, didn't look at any actual code.

GSF19

2004-12-10 04:31

reporter   ~0008577

yeap hide-ulines is enabled.. (i know my english sux but i'm working on it..) so syzop the question is since when flat map isnt enable it also hides the servers behind the ulined server.. couldnt it be fixed so the same thing happens when flat map is enabled? the code would be the same but it in the end the ircd would show it in flat mode.

codemastr

2004-12-10 11:24

reporter   ~0008579

[quote]I was thinking, are servers behind u-lines actually u-lined too?[/quote]
They should be. I added code to do that (if uplink is ulined, SetUline). But I guess it is possible that somehow the code got broken.

syzop

2004-12-10 11:37

administrator   ~0008580

Hm, I see the code indeed :).
I'll take a look at this issue (wherever the bug is, ulines/flat-map)

syzop

2004-12-10 14:51

administrator   ~0008584

Hm, I'm having trouble reproducing this :p.
Could you try the '/map' thing from several servers closer/far away from services and see if you get different results?
I tried /map from A in juped-services-A, and /map from B in juped-services-A-B, but in both case both the services server and the juped server were hidden.

syzop

2004-12-10 14:56

administrator   ~0008585

BEEP.. Ignore that :P.

syzop

2004-12-10 15:12

administrator   ~0008586

'cptr' is confusing again.. I didn't know in a message :serv1 BLAH.. and in layout: serv1<->serv2<->WE that cptr would be &me then... what use is cptr then, lol? :P (I thought cptr would be sptr->from).

Anyway, that's the bug then:
    if (IsULine(cptr)
        || (Find_uline(acptr->name)))
        acptr->flags |= FLAGS_ULINE;
should be:
    if (IsULine(sptr)
        || (Find_uline(acptr->name)))
        acptr->flags |= FLAGS_ULINE;
I think.

(which makes me wonder why this (old) code does:
    acptr = make_client(cptr, find_server_quick(parv[0]));
 since AFAIK the find_* thing could have just used sptr :P)

syzop

2004-12-10 15:21

administrator   ~0008587

Fixed in .209.

Issue History

Date Modified Username Field Change
2004-12-09 20:11 GSF19 New Issue
2004-12-09 20:20 aquanight Note Added: 0008568
2004-12-09 20:21 aquanight Note Edited: 0008568
2004-12-09 20:39 GSF19 Note Added: 0008569
2004-12-09 20:39 GSF19 Note Edited: 0008569
2004-12-09 22:35 codemastr Note Added: 0008571
2004-12-09 23:29 syzop Note Added: 0008573
2004-12-10 04:31 GSF19 Note Added: 0008577
2004-12-10 11:24 codemastr Note Added: 0008579
2004-12-10 11:37 syzop Note Added: 0008580
2004-12-10 14:51 syzop Note Added: 0008584
2004-12-10 14:56 syzop Note Added: 0008585
2004-12-10 15:12 syzop Note Added: 0008586
2004-12-10 15:21 syzop Status new => resolved
2004-12-10 15:21 syzop Fixed in Version => 3.2.3
2004-12-10 15:21 syzop Resolution open => fixed
2004-12-10 15:21 syzop Assigned To => syzop
2004-12-10 15:21 syzop Note Added: 0008587
2004-12-10 15:21 syzop Assigned To syzop =>
2004-12-10 15:22 syzop Assigned To => syzop
2004-12-10 15:22 syzop Build latest devel => (ALL: 3.2*)