View Issue Details

IDProjectCategoryView StatusLast Update
0002237unrealdocumentationpublic2015-05-27 18:13
ReporteraquanightAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformX86OSWindowsOS VersionXP Pro SP2
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002237: help.conf: REHASH documented to clear temporary klines when it actually does not
Description***** Rehash *****
 -
 Prompts the server to reread the configuration files.
 IRC Operator only command.
 -
 Syntax: REHASH <servername> -<flags>
         REHASH -<flags>
 -
 If servername and flags are not specified this rehashes the
 unrealircd.conf , ***** removing any temporary k:lines. *****
 If servername is specified, this is used to rehash config files on servername.
 Only NetAdmins may specify a server name.
 -
 The flags are used to rehash other config files, valid flags are:
  -motd - Rehashes all MOTD files and RULES files (including tld{})
  -opermotd - Rehashes the OPERMOTD
  -botmotd - Rehashes the BOTMOTD
  -garbage - Force garbage collection
 -
[23:10:34] -*- *** Permanent K:Line added for test@test.com on Sun Dec 12 06:10:31 2004 GMT (from aquanight!~aquanight@*: Testing)
K test@test.com 0 9 aquanight!~aquanight@* Testing
End of /STATS report
^ -- Added a kline to try it
[23:10:45] -*- *** Notice -- aquanight is rehashing server config file
unrealircd.conf Rehashing
[23:10:52] -*- *** Notice -- Loading IRCd configuration ..
[23:10:52] -*- *** Notice -- Configuration loaded without any problems ..
^ -- helpop says rehash would clear it.
K test@test.com 0 13 aquanight!~aquanight@* Testing
End of /STATS report
^ -- still there?
[23:10:59] -*- aquanight!~aquanight@* removed K:Line test@test.com (set at Sun Dec 12 06:10:31 2004 - reason: Testing)
[23:11:14] -*- *** K:Line added for test@test.com on Sun Dec 12 06:11:14 2004 GMT (from aquanight!~aquanight@* to expire at Wed Dec 15 06:11:14 2004 GMT: Testing)
K test@test.com 259200 0 aquanight!~aquanight@* Testing
End of /STATS report
^ -- trying it again with a really-temporary kline
[23:11:18] -*- *** Notice -- aquanight is rehashing server config file
unrealircd.conf Rehashing
[23:11:22] -*- *** Notice -- Loading IRCd configuration ..
[23:11:22] -*- *** Notice -- Configuration loaded without any problems ..
^ -- helpop says rehash would clear it.
K test@test.com 259196 4 aquanight!~aquanight@* Testing
End of /STATS report
^ -- still there?!

So either help.conf is wrong or /rehash is wrong. And from what I've heard on forums/etc, it's most likely help.conf ;)

Also I think it'd be nice to have slightly better documentation on what the fields in the TKL form of the stats K replies mean (like the 259196 4 mean in the last example, I assume it's expiry and age, but...?).
Steps To Reproduce- Add a KLINE.
- Type /stats K or /kline to verify that it's there.
- Rehash (/rehash or SIGHUP should do...)
- Do /stats K or /kline again. It's still there. Now do /helpop ?rehash, it says the tklines should be wiped.
TagsNo tags attached.
3rd party modules

Activities

codemastr

2004-12-12 15:07

reporter   ~0008626

You're right. This is a result of the fact that /kline now uses TKL rather than the old "pseudo-config-entry" method.

medice

2004-12-15 12:20

reporter   ~0008633

In my opinion it's a good thing that ?whatever?lines are not purged on /rehash anymore - have a slightly change in ircd-conf - and you're whole lineing was gone...

but sometimes it might be useful and it's intended to clean it all up (lame locops who made permanent kline/zlines *ggg*) - maybe you can create some "/rehash -<flag>" to provide this

Stealth

2004-12-15 16:09

reporter   ~0008636

Last edited: 2004-12-15 16:10

Is there any reason some bugnotes are not showing?

2004-12-14 20:06 syzop Note Added: 0008632
2004-12-15 12:29 codemastr Note Added: 0008634

These 2 bugnotes are not showing in the notes section, but are in the issue history...


EDIT: They arent sent in any of the emails either.

syzop

2004-12-15 16:25

administrator   ~0008637

they are private :)

syzop

2015-05-27 18:13

administrator   ~0018353

Has been done 10+ years ago. Don't ask me which version ;)

Issue History

Date Modified Username Field Change
2004-12-12 01:34 aquanight New Issue
2004-12-12 15:07 codemastr Note Added: 0008626
2004-12-12 15:07 codemastr Status new => confirmed
2004-12-15 12:20 medice Note Added: 0008633
2004-12-15 16:09 Stealth Note Added: 0008636
2004-12-15 16:10 Stealth Note Edited: 0008636
2004-12-15 16:25 syzop Note Added: 0008637
2015-05-27 18:13 syzop Note Added: 0018353
2015-05-27 18:13 syzop Status confirmed => resolved
2015-05-27 18:13 syzop Fixed in Version => 3.2.3
2015-05-27 18:13 syzop Resolution open => fixed
2015-05-27 18:13 syzop Assigned To => syzop