View Issue Details

IDProjectCategoryView StatusLast Update
0002248unrealircdpublic2005-01-17 15:11
ReporteraquanightAssigned Tocodemastr 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformX86OSWindowsOS VersionXP Pro SP2
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002248: Channel +f flood notices target is "incorrect"
DescriptionThe notices sent for +f activity are sent to (half)ops on the channel, but the target field of the actual NOTICE message to clients is @%#channel, when normal notice-to-halfops by a client is set with just % (even to ops).

Example:
[17:21:55] * Mode (aquanight): +f [1c#C30,5j#i10,20m#m10,2n#N30,5t]:10
[SNIP bot parting/joining a few times]
[17:22:13] -irc.*:@%#channel- *** Channel joinflood detected (limit is 5 per 10 seconds), setting mode +i
[17:22:13] * Mode (irc.*): +i
[SNIP same bot pinging channel twice]
[17:22:45] -irc.*:@%#channel- *** Channel CTCPflood detected (limit is 1 per 10 seconds), setting mode +C
[17:22:45] * Mode (irc.*): +C
[SNIP bunch of messages from bot (is opered, so no textflood kick (intended?))]
[17:25:19] -irc.*:@%#channel- *** Channel msg/noticeflood detected (limit is 20 per 10 seconds), setting mode +m
[17:25:19] * Mode (irc.*): +m
[17:30:23] -Bot:%#channel- Hi

Note the standard halfopnotice (even though it went to ops) didn't have the @, but the flood notices do... I don't think it's that big of a deal, but IIRC, the need for multiple prefixes WAS removed, so why is a notice being sent with multiple prefixes...? :)
Steps To Reproduce- Set a +f string. Have another client trigger the flood alert. The notice is to @%#channel.
- Have a voiced/halfopped/opped/whatever client do a /notice to %#channel and @%#channel, notice generated is to %#channel.
Additional InformationAs I said, multiple prefixes were removed IIRC, but this still remains for some reason...
TagsNo tags attached.
3rd party modules

Activities

syzop

2004-12-20 19:53

administrator   ~0008652

True, that should be fixed then.

codemastr

2005-01-17 15:10

reporter   ~0008838

Fixed in .226

Issue History

Date Modified Username Field Change
2004-12-20 19:47 aquanight New Issue
2004-12-20 19:53 syzop Note Added: 0008652
2004-12-20 19:53 syzop Status new => acknowledged
2005-01-17 15:10 codemastr Status acknowledged => resolved
2005-01-17 15:10 codemastr Fixed in Version => 3.2.3
2005-01-17 15:10 codemastr Resolution open => fixed
2005-01-17 15:10 codemastr Assigned To => codemastr
2005-01-17 15:10 codemastr Note Added: 0008838
2005-01-17 15:11 codemastr Category documentation => ircd