View Issue Details

IDProjectCategoryView StatusLast Update
0002288unrealircdpublic2005-01-22 13:15
ReporterFreadonAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform*NixOSRed Hat LinuxOS Versionrelease 9 (Shrik
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002288: Whois Notification Problem
DescriptionHi, I'm on a network with 7 servers,
im connecting from a link server. have modes +iowghraARVxNWvt and snomasks +kcfvGqso when somone whoises me from another link i cant see the notification message, when someone whoises me from the server im connecting from i can see the message. there was no problem before i upgraded to Unreal3.2.2 tehere was no problem with Unreal3.2.1. am using
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-01-17 20:23

administrator   ~0008846

works fine here (but I can only test 3.2.2<->3.2.2).
Also IIRC nothing got changed in +W in the past versions.

Did you try with 0 servers in between? so 2 directly linked servers?

syzop

2005-01-17 20:25

administrator   ~0008847

Oh and, assuming A is the person with umode +W, and B is not...
Then, could B (as an oper) set /mode B +s +ej, and then /whois A... and then check if the showed 'A has usermodes +blablabla' is correct?

Freadon

2005-01-17 20:41

reporter   ~0008848

Everything looks fine but. cant see anything

Freadon

2005-01-18 07:35

reporter   ~0008850

It Was a problem with user mode R when i have +RW i cant see any messages when i remove the R umode i can see the notification mesages

White_Magic

2005-01-18 09:42

reporter   ~0008851

but how does +R affect the servers telling someone /whois you.

Freadon

2005-01-18 09:54

reporter   ~0008852

White_Magic, I dont know and thats the point

White_Magic

2005-01-18 10:41

reporter   ~0008853

possibly the nickname maybe isnt registered and when they do /whois its processing +R over +W - as in, since +R stops unregistered messages notices and it contains the nickname possibly that is blocking it?

codemastr

2005-01-18 11:58

reporter   ~0008854

Well, nothing in the /whois code does anything with +R. I'll look into this, but I certainly can't see how this can occur.

syzop

2005-01-18 15:08

administrator   ~0008859

Hm, confirmed on latest CVS.

200 if (*nick != '#' && (acptr = find_person(nick, NULL)))
(gdb)
202 if (IsVirus(sptr))
(gdb)
208 if (IsRegNickMsg(acptr) && !IsRegNick(sptr) && !IsULine(sptr) && !IsOper(sptr)) {
(gdb)
209 sendto_one(sptr, err_str(ERR_NONONREG), me.name, parv[0],
(gdb)
211 return 0;

heh
207 /* Umode +R (idea from Bahamut) */
208 if (IsRegNickMsg(acptr) && !IsRegNick(sptr) && !IsULine(sptr) && !IsOper(sptr)) {
209 sendto_one(sptr, err_str(ERR_NONONREG), me.name, parv[0],
210 acptr->name);
211 return 0;
212 }

no IsServer check :p

Freadon

2005-01-19 16:37

reporter   ~0008863

White_Magic , i checked it several times, i tryed it with registered and non registered users, if you have +R you cant get the mesage , codemastr but when i have -R it works it must have something to do with. something.

codemastr

2005-01-22 13:15

reporter   ~0008890

Fixed in .234

Issue History

Date Modified Username Field Change
2005-01-17 20:21 Freadon New Issue
2005-01-17 20:23 syzop Note Added: 0008846
2005-01-17 20:25 syzop Note Added: 0008847
2005-01-17 20:41 Freadon Note Added: 0008848
2005-01-18 07:35 Freadon Note Added: 0008850
2005-01-18 09:42 White_Magic Note Added: 0008851
2005-01-18 09:54 Freadon Note Added: 0008852
2005-01-18 10:41 White_Magic Note Added: 0008853
2005-01-18 11:58 codemastr Note Added: 0008854
2005-01-18 15:08 syzop Note Added: 0008859
2005-01-19 16:37 Freadon Note Added: 0008863
2005-01-22 13:15 codemastr Status new => resolved
2005-01-22 13:15 codemastr Fixed in Version => 3.2.3
2005-01-22 13:15 codemastr Resolution open => fixed
2005-01-22 13:15 codemastr Assigned To => codemastr
2005-01-22 13:15 codemastr Note Added: 0008890