View Issue Details

IDProjectCategoryView StatusLast Update
0002299unrealircdpublic2005-01-29 13:01
ReporterRockoAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebian Woody 3.0OS Version2.4.26
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002299: /stats confusion, documentation bugs
DescriptionApart from the case, that /stats k/g/o/m were always in lower case, and some scripts still supports the lower case stats flags, there are documentation bugs in /stats as well.

1. Stats E doesn't mention except TKL. (This was added here: http://bugs.unrealircd.org/view.php?id=1524)

2. *** G - gline - Send the gline list
This is wrong too, it also lists GZLINES.

3. This part here isn't sorted in an alphabetical order:
*** M - command - Send list of how many times each command was used
*** n - banrealname - Send the ban realname block list
*** O - oper - Send the oper block list
*** S - set - Send the set block list
*** s - shun - Send the shun list
*** Extended flags: [+/-mrs] [mask] [reason] [setby]
*** m Return shuns matching/not matching the specified mask
*** r Return shuns with a reason matching/not matching the specified reason
*** s Return shuns set by/not set by clients matching the specified name
*** P - port - Send information about ports
*** q - bannick - Send the ban nick block list
*** Q - sqline - Send the global qline list
*** r - chanrestrict - Send the channel deny/allow block list
*** t - tld - Send the tld block list
*** T - traffic - Send traffic information

4. Don't forget to update the /stats ? output in m_stats.c and in the unrealircd documentation.

5. Why is /stats M in a capital letter instead of the normal /stats m as it was earlier and in other ircds and scripts.
I can understand the reason for stats G/K/O to be in capital letters, because the output is somethinkg like O *@*, G *@*.com.. but not for M.
Furthermore /stats M hasn't a "backwards compatibility" like g/k/o, which still works. Just my opinion..
TagsNo tags attached.
3rd party modules

Activities

codemastr

2005-01-23 12:34

reporter   ~0008899

[quote]Apart from the case, that /stats k/g/o/m were always in lower case, and some scripts still supports the lower case stats flags, there are documentation bugs in /stats as well.[/quote]
What?

Rocko

2005-01-23 13:43

reporter   ~0008901

I think, /stats K/G/O/M, as it's now today, were /stats k/g/o/m (lower case) in earlier versions, I don't know exactly. I know, that my script (I use PnP, and many other People also use it, as a result from a poll from the quakenet) uses for global bans /stats g, local bans /stats k, commands /stats m, /stats o for Olines, also other IRCds like bahamut behave that way.
There is no problem with that, because /stats o/g/k (EXCEPT /stats m) still works.
I just wonder, why it isn't lower case (anymore). The documentation says /stats G/K/O/M would be correct.

codemastr

2005-01-29 12:46

reporter   ~0008939

Fixed in .241

Issue History

Date Modified Username Field Change
2005-01-23 07:10 Rocko New Issue
2005-01-23 12:34 codemastr Note Added: 0008899
2005-01-23 13:43 Rocko Note Added: 0008901
2005-01-29 12:46 codemastr Status new => resolved
2005-01-29 12:46 codemastr Resolution open => fixed
2005-01-29 12:46 codemastr Assigned To => codemastr
2005-01-29 12:46 codemastr Note Added: 0008939
2005-01-29 13:01 codemastr Fixed in Version => 3.2.3