View Issue Details

IDProjectCategoryView StatusLast Update
0002306unrealircdpublic2005-01-29 13:00
ReporterWhite_MagicAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002306: /Invite bug / Bad Documentation Of /Invite
Description***** Invite *****
 -
 Sends a user an Invitation to join a particular channel.
 You must be an Operator on the channel in order to
 invite a user into it.
 -
 Syntax: INVITE <user> <channel>
 Example: INVITE hAtbLaDe #Support

[14:47] * carebearclaire (Xscript60@Chatuniverse-5FA35A2A.ipt.aol.com) invites you to join #wickedte3nz
-
carebearclaire is Xscript60@Chatuniverse-5FA35A2A.ipt.aol.com * XstaticScriptv60 - Final
carebearclaire is using modes +iTx
carebearclaire on #wickedte3nz
carebearclaire using Storm.ChatUniverse.net Take Cover theres a Storm Comming
carebearclaire End of /WHOIS list.

carebearclaire is not an op yet she can /invite users to the channel. Either this is a bug (becuz she has no ops and can invite) or the ircd helpop textis wrong in claiming you need ops to use /invite
TagsNo tags attached.
3rd party modules

Activities

White_Magic

2005-01-26 10:06

reporter   ~0008926

sorry ircd version 3.2.2b and below as far 3.2.1 i know seem to be affected

aquanight

2005-01-26 11:53

reporter   ~0008927

Last edited: 2005-01-26 11:54

When the channel is set +i, chanop privileges are required to use /invite. Also, setting the channel +V would effectively require ops since no one can invite when +V is set but chanops can remove +V to invite someone...

*edit* But of course, when neither +i or +V is set, anyone (in the channel) can invite anyone to the channel, so yeah... */edit*

medice

2005-01-26 17:48

reporter   ~0008930

as far as I know this is by design like aquanight explained in detail...
i believe many ircds are handleing /invite like this...

codemastr

2005-01-29 12:59

reporter   ~0008941

The documentation is updated in .242

Issue History

Date Modified Username Field Change
2005-01-26 10:04 White_Magic New Issue
2005-01-26 10:06 White_Magic Note Added: 0008926
2005-01-26 11:53 aquanight Note Added: 0008927
2005-01-26 11:54 aquanight Note Edited: 0008927
2005-01-26 17:48 medice Note Added: 0008930
2005-01-29 12:59 codemastr Status new => resolved
2005-01-29 12:59 codemastr Resolution open => fixed
2005-01-29 12:59 codemastr Assigned To => codemastr
2005-01-29 12:59 codemastr Note Added: 0008941
2005-01-29 13:00 codemastr Fixed in Version => 3.2.3