View Issue Details

IDProjectCategoryView StatusLast Update
0002313unrealinstallingpublic2007-04-19 04:36
ReporterTommyTheKid Assigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOSXOS Version10.3.7
Product Version3.2.2 
Summary0002313: make install misses spamfilter.conf and server.*.pem
Descriptionafter installing ircd (using make install) it wont run because its missing a couple files.. should be pretty easy to fix.. am I the only one who doesnt run out of the source directory? :)
Steps To Reproduce./Config (enable SSL in the config .. and specify somewhere else to install ~/etc ~/bin for example..)

make

make install

then configure...

./unreal start

(yeck no spamfilter.conf .. nor server.cert.pem or server.key.pem which can all be copied out of the src/Unreal3.2 directory
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0002423 closed make install does not install SSL certificate files 

Activities

Stealth

2005-02-01 23:09

reporter   ~0008979

I have seen this myself when Unreal gets installed to ~/Unreal.

I will be attacthing a list of the files it copied as soon as I can pry it out of my VM. :\

2005-02-01 23:23

 

file_list.txt (2,666 bytes)

syzop

2005-02-03 20:52

administrator   ~0009020

Last edited: 2005-02-03 20:52

spamfilter.conf should be included indeed. And when we are at it, dccallow.conf too.

However, should server.*.pem be copied as well? If you are upgrading from a previous version, in a clean directory, then it would prompt for SSL certs.. I usually just hold down enter all the time then, but then when doing make install your good cert will be overwritten by this useless one..
So hm, it probably should not copy that one if it already exists? :P.
[One could say this is true for all the other *.conf files, but you just shouldn't be touching them since they get updated by us from time to time {ok, last update to badwords.message.conf is 21 months ago but you get the idea.. spamfilter.conf and dccallow.conf are updated :p}]

syzop

2005-02-26 18:07

administrator   ~0009321

[in my queue:]
- spamfilter.conf and dccallow.conf are now also copied upon make install, reported by TommyTheKid (0002313).

I'll leave the bug open for the rest, but the copy-only-if-not-present will not be done in 3.2.3.

Issue History

Date Modified Username Field Change
2005-02-01 23:01 TommyTheKid New Issue
2005-02-01 23:09 Stealth Note Added: 0008979
2005-02-01 23:23 Stealth File Added: file_list.txt
2005-02-03 20:52 syzop Note Added: 0009020
2005-02-03 20:52 syzop Note Edited: 0009020
2005-02-26 18:07 syzop Note Added: 0009321
2005-03-13 18:01 syzop Relationship added has duplicate 0002423
2007-04-19 04:36 stskeeps Status new => resolved
2007-04-19 04:36 stskeeps Resolution open => fixed
2007-04-19 04:36 stskeeps Assigned To => stskeeps