View Issue Details

IDProjectCategoryView StatusLast Update
0002325unrealircdpublic2005-02-25 13:51
ReportervonitsanetAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLINUXOSOS Version2.4.21-20.EL.c0
Product Version3.2.3 
Target VersionFixed in Version3.2.3 
Summary0002325: Sajoin notice send the channel double.
Descriptionif i do
/sajoin ME #TEST

-SERVER- *** You were forced to join #test,#test
-
-SERVER- *** Notice -- ME used SAJOIN to make ME join #test,#test
Steps To Reproduce
Sajoin yourserv to some channel.
You will See on the notice the channel(s) double time.
TagsNo tags attached.
3rd party modulesm_jumpserver , m_privdeaf

Activities

w00t

2005-02-09 10:54

reporter   ~0009054

Are you referring to the fact you got told you were force joined, and then the oper notice?

If so-- does it really matter? Is it worth adding another check just to stop that?

aquanight

2005-02-09 12:08

reporter   ~0009055

No I think he's referring to the fact that the channel is listed twice in the notice... :) (EG, the odd #test,#test thingy.)

Stealth

2005-02-09 15:21

reporter   ~0009056

I am unable to reproduce this. Everything is normal when I sajoin myself to channels. I tried both empty channels and channels with users.

crazy

2005-02-09 16:52

reporter   ~0009057

hmmm.. I can reproduce this on the last CVS ...(but not on 3.2.2 + patch )

[22:33:28] * *** You were forced to join #test,#test
[22:33:28] * crazy used SAJOIN to make crazy join #test,#test
[22:34:10] * *** You were forced to join #omg,#omg
[22:34:10] * crazy used SAJOIN to make crazy join #omg,#omg

Troco

2005-02-09 18:47

reporter   ~0009058

/sajoin Troco #prueba
*** You were forced to join #prueba,#prueba
Troco used SAJOIN to make Troco join #prueba,#prueba

It's since another bug was resolved in .232 (bugid 2293)

w00t

2005-02-10 00:33

reporter   ~0009061

Oh, right. sajoin on multiple channels.

codemastr

2005-02-25 13:51

reporter   ~0009310

Fixed in .286

Issue History

Date Modified Username Field Change
2005-02-09 08:26 vonitsanet New Issue
2005-02-09 08:26 vonitsanet 3rd party modules => m_jumpserver , m_privdeaf
2005-02-09 10:54 w00t Note Added: 0009054
2005-02-09 12:08 aquanight Note Added: 0009055
2005-02-09 15:21 Stealth Note Added: 0009056
2005-02-09 16:52 crazy Note Added: 0009057
2005-02-09 18:47 Troco Note Added: 0009058
2005-02-10 00:33 w00t Note Added: 0009061
2005-02-25 13:51 codemastr Status new => resolved
2005-02-25 13:51 codemastr Fixed in Version => 3.2.3
2005-02-25 13:51 codemastr Resolution open => fixed
2005-02-25 13:51 codemastr Assigned To => codemastr
2005-02-25 13:51 codemastr Note Added: 0009310