View Issue Details

IDProjectCategoryView StatusLast Update
0002333unrealircdpublic2005-02-26 18:13
ReportersenecesAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.3 
Summary0002333: Halfops exempt from +f #t?
DescriptionCurrently, channel ops are exempt from flood protection (mode +f). What about halfops? I don't see any reason they shouldn't be exempt.
TagsNo tags attached.
3rd party modules

Activities

aquanight

2005-02-12 12:16

reporter   ~0009095

On the other hand, why SHOULD they be exempt? :P

seneces

2005-02-12 14:53

reporter   ~0009105

Well, if someone is trusted enough to have halfops and the ability to kick/ban users and set (some) modes, you should hope they won't spam.

devil

2005-02-23 11:56

reporter   ~0009264

Hope kills.. if they get hacked your screwed =)

codemastr

2005-02-24 23:55

reporter   ~0009291

[quote]Hope kills.. if they get hacked your screwed =)[/quote]
Irrelevant. If that's the case, no one should be exempt from +f, not even a user who is +q nor a netadmin because anyone can be hacked. In fact, we shouldn't even have +q or netadmins because that simply amplifies the problem if someone is hacked! In short, the threat of a user being hacked is never a good excuse in this context because all it does is suggest that *all* power should be removed which is not feasible.

syzop

2005-02-26 17:58

administrator   ~0009320

assigned.
I presume the reporter means +f #t (per-user textflood), this indeed seems to affect halfops.

syzop

2005-02-26 18:13

administrator   ~0009323

Fixed in .288.

Issue History

Date Modified Username Field Change
2005-02-12 03:27 seneces New Issue
2005-02-12 12:16 aquanight Note Added: 0009095
2005-02-12 14:53 seneces Note Added: 0009105
2005-02-23 11:56 devil Note Added: 0009264
2005-02-24 23:55 codemastr Note Added: 0009291
2005-02-26 17:56 syzop Summary Halfops exempt from +f? => Halfops exempt from +f #t?
2005-02-26 17:58 syzop Note Added: 0009320
2005-02-26 17:58 syzop Status new => assigned
2005-02-26 18:13 syzop Status assigned => resolved
2005-02-26 18:13 syzop Fixed in Version => 3.2.3
2005-02-26 18:13 syzop Resolution open => fixed
2005-02-26 18:13 syzop Assigned To => syzop
2005-02-26 18:13 syzop Note Added: 0009323