View Issue Details

IDProjectCategoryView StatusLast Update
0002349unrealdocumentationpublic2005-02-27 20:24
ReporterFolkenAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSLinuxOS Version2.6.10
Product Version3.2.2 
Target VersionFixed in Version3.2.3 
Summary0002349: Where to find information about precedence of oper modes
DescriptionHi, I'd like to know where to get info on what is the precedence of oper modes.

i.e.: I've added an oper block assigning helpop, can_gkline, can_override to a user and every command (gline, shun, mode walking) return an "insufficient privileges" error.

Thanks in advance, and best Regards
Folken.
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-02-18 15:02

administrator   ~0009165

Be sure to rehash, and /mode yourself -o, and /oper up again after doing that.
Also make sure you are not a local oper.

Folken

2005-02-18 15:22

reporter   ~0009166

People using this oper block is reconnecting every time, they log-in and /oper everytime I make a change.

Right now, the block looks like:

oper Helper {
        class clients;
        from {
                userhost *@*;
        };
        password "passwordhere";
        flags {
                helpop;
                can_override;
                can_gkline;
        };
};

Still, they cant perform overrides or setting /spamfilters and such...

Btw, that was a quick response, thanks :)

codemastr

2005-02-18 15:24

reporter   ~0009167

Only global opers and above can use those kind of commands. That oper block is for a local oper.

syzop

2005-02-18 15:24

administrator   ~0009168

Last edited: 2005-02-18 15:25

Right, that user is a local oper, since you didn't specify 'global', 'coadmin', 'admin', etc... anywhere.
Local opers cannot get these global privileges (walking trough channel modes, putting global klines [glines], etc).

*edit* too slow :( */edit*

Folken

2005-02-18 15:34

reporter   ~0009169

Right, thats why I was asking about precedence, thanks guys for your time.

Now I'll try to figure out how to assign specific privileges to some users, since I dont want them to be global operators, as globops includes too many permissions.

Folken

2005-02-20 03:22

reporter   ~0009189

OK I've resolved it making an anope module to
SVSO nick -
SVSMODE nick +o
SVSO nick +th

I guess this case is closed :)

Thanks again for your time and patience.

syzop

2005-02-27 20:24

administrator   ~0009344

if you now specify can_gkline/can_override/can_gzline the block is auto converted to globop (+warning), see changelog for more details.

Issue History

Date Modified Username Field Change
2005-02-18 15:01 Folken New Issue
2005-02-18 15:02 syzop Note Added: 0009165
2005-02-18 15:22 Folken Note Added: 0009166
2005-02-18 15:24 codemastr Note Added: 0009167
2005-02-18 15:24 syzop Note Added: 0009168
2005-02-18 15:25 syzop Note Edited: 0009168
2005-02-18 15:34 Folken Note Added: 0009169
2005-02-20 03:22 Folken Note Added: 0009189
2005-02-27 20:24 syzop Status new => resolved
2005-02-27 20:24 syzop Fixed in Version => 3.2.3
2005-02-27 20:24 syzop Resolution open => fixed
2005-02-27 20:24 syzop Assigned To => syzop
2005-02-27 20:24 syzop Note Added: 0009344