View Issue Details

IDProjectCategoryView StatusLast Update
0002383unrealircdpublic2005-03-04 12:44
ReportertrystanscottAssigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi686OSRedhat LinuxOS Version7.3
Product Version3.2.3 
Target VersionFixed in Version3.2.3 
Summary0002383: Invite with no parameters prints garbage
Description/INVITE with no parameters does not properly lists the channels that user is invited to (but have not yet joined).

[21:34] * Trystan (Trystan@NomadInc.net) invites you to join #ircops
-
#ircops ˆ™#HŸ#(€#
End of /INVITE list.

In m_invite

sendto_one(sptr, rpl_str(RPL_INVITELIST), me.name, sptr->name,
               inv->value.chptr->chname);

RPL_INVITELIST */ ":%s 336 %s %s :%s",

Not that great with the Unreal code but it looks likes an extra %s in there, or a missing variable.
Steps To Reproduce1. Invite yourself to a channel but do not join
2. /invite with no parameters
TagsNo tags attached.
3rd party modules

Activities

codemastr

2005-03-04 12:44

reporter   ~0009399

Fixed in .317

Issue History

Date Modified Username Field Change
2005-03-04 00:28 trystanscott New Issue
2005-03-04 12:44 codemastr Status new => resolved
2005-03-04 12:44 codemastr Fixed in Version => 3.2.3
2005-03-04 12:44 codemastr Resolution open => fixed
2005-03-04 12:44 codemastr Assigned To => codemastr
2005-03-04 12:44 codemastr Note Added: 0009399