View Issue Details

IDProjectCategoryView StatusLast Update
0002388unrealircdpublic2005-11-10 18:43
ReportervonitsanetAssigned Tostskeeps 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformAllOSOS Version
Product Version3.2.2 
Target VersionFixed in Version3.2.4 
Summary0002388: You can change your nick TO a banned one in a channel.
Description1) * fuck has join #channel
2) * OPERATOR sets mode: +b *fuck*!*@*
3) * fuck was kicked by OPERATOR (Change your nick)
4) * Lamer1 has join #channel
5) * Lamer1 is known as fuck (the ban exist)

The summary of this is:
You CAN change your nick to a banned one in a channel.

It will be nice if this can be blocked with some way so we can always have stick bans to prevent changes to these type of nicknames.
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-03-04 18:03

administrator   ~0009420

I think we had this before, and I closed it.. because I didn't see any reason to block it.. because if someone wants to be banned.. why should we stop him? ;)

Anyway, now I can understand that perhaps you do not want certain nicks as a kind of 'policy', like 'fuck' etc... then it seems to make more sense.

[not for 3.2.3]

vonitsanet

2005-03-04 18:09

reporter   ~0009421

[quote] Anyway, now I can understand that perhaps you do not want certain nicks as a kind of 'policy', like 'fuck' etc... then it seems to make more sense. [/quote]

syzop exactly this:)

[quote] not for 3.2.3 [/quote]

I can wait for 3.2.4 :P

vonitsanet

2005-03-16 03:10

reporter   ~0009609

3.2.3 is finally released :)

syzop is possible to take a look for this for version 3.2.4 sometime..:)

syzop

2005-03-16 17:23

administrator   ~0009612

I don't know how much work it is from the top of my head, but I've added it to the TODO.

vonitsanet

2005-06-08 08:26

reporter   ~0010070

My apologise if I become insistent but can we take a look on this for 3.2.4?

Nazzy

2005-11-07 20:31

reporter   ~0010660

I should have a patch for this some time tomorrow :)

vonitsanet

2005-11-08 09:56

reporter   ~0010667

i think it will be useful for many users here.

syzop

2005-11-08 09:58

administrator   ~0010668

For what it's worth, this feature was added to the 3.2.4 todo list on March 2005. It has always been my intention to add it in 3.2.4.

Actually I said so already ;).

stskeeps

2005-11-08 10:16

reporter   ~0010670

I've got Nazzy working on this one, assigning it to me

vonitsanet

2005-11-08 10:28

reporter   ~0010672

Is possible for us to see the TODO list for the next release (not just 3.2.4 i mean every release) just to know what are we waiting for and also not post for features/fixes that are planned already to be added?

syzop

2005-11-08 11:06

administrator   ~0010673

No, sorry I would like to keep that private: will save me a lot of annoyances and useless discussions. And just as important: roughly half of the 3.2.<something> TODO list does not get done (read: false expectations), and (more than) half other things that were unlisted are done (read: TODO not as useful as you might think).

That said, for this issue, I already said it was on TODO in March (oh ok, perhaps it wasn't clear I meant for 3.2.4).

Nazzy

2005-11-10 17:05

reporter   ~0010687

Sorry for delay, being ill is terrible for productivity :(

2005-11-10 17:06

 

include_h_h.patch (705 bytes)

2005-11-10 17:06

 

src_channel_c.patch (4,750 bytes)

2005-11-10 17:06

 

src_modules_m_nick_c.patch (841 bytes)

Nazzy

2005-11-10 17:14

reporter   ~0010688

As a point .... a couple of people have suggested that it would be nice to make this a definable behaviour. I said I'd pass it on with the patches :)

2005-11-10 18:40

 

committed_diff_395 (9,685 bytes)

syzop

2005-11-10 18:43

administrator   ~0010689

Thanks, committed [.395].

As you can see I changed your patch a bit, first of all.. I made it configurable indeed ;p.
Besides that, I did not do the is_banned_with_nick the way you did, because that creates too much duplicate code (== bad with maintaining), but instead made is_banned() a simple wrapper for is_banned_with_nick().

I've attached the committed_diff_395 as well.

Issue History

Date Modified Username Field Change
2005-03-04 17:58 vonitsanet New Issue
2005-03-04 18:02 syzop Summary You CAN change your nick to a banned one in a channel. => You can change your nick TO a banned one in a channel.
2005-03-04 18:03 syzop Note Added: 0009420
2005-03-04 18:09 vonitsanet Note Added: 0009421
2005-03-16 03:10 vonitsanet Note Added: 0009609
2005-03-16 17:23 syzop Note Added: 0009612
2005-06-08 08:26 vonitsanet Note Added: 0010070
2005-11-07 20:31 Nazzy Note Added: 0010660
2005-11-08 09:56 vonitsanet Note Added: 0010667
2005-11-08 09:58 syzop Note Added: 0010668
2005-11-08 10:16 stskeeps Note Added: 0010670
2005-11-08 10:17 stskeeps Status new => assigned
2005-11-08 10:17 stskeeps Assigned To => stskeeps
2005-11-08 10:28 vonitsanet Note Added: 0010672
2005-11-08 11:06 syzop Note Added: 0010673
2005-11-10 17:05 Nazzy Note Added: 0010687
2005-11-10 17:06 Nazzy File Added: include_h_h.patch
2005-11-10 17:06 Nazzy File Added: src_channel_c.patch
2005-11-10 17:06 Nazzy File Added: src_modules_m_nick_c.patch
2005-11-10 17:14 Nazzy Note Added: 0010688
2005-11-10 18:40 syzop File Added: committed_diff_395
2005-11-10 18:43 syzop Status assigned => resolved
2005-11-10 18:43 syzop Fixed in Version => 3.2.4
2005-11-10 18:43 syzop Resolution open => fixed
2005-11-10 18:43 syzop Note Added: 0010689