View Issue Details

IDProjectCategoryView StatusLast Update
0002391unrealircdpublic2005-03-05 15:46
ReporterRon2KAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindows XP ProOS VersionSP2
Product Version3.2.3 
Target VersionFixed in Version3.2.3 
Summary0002391: Chmodes +p/+s and +S/+c - possible desynch
Description(Tested with Unreal3.2.3-pre2)

I've just discovered a desynch on netmerge with chmodes +p/+s and +S/+c.

What I did was the following:
- Created channel #test with two users (on different servers). Both had channel operator privileges.
- The two servers were then split.
- On server1, channel mode +p was set; channel mode +s was set on server2
- The two servers were then merged.
- On server1, -p+s was set; on server2, -s+p was set. (If that isn't a desynch, then I don't know what is.)

Obviously, the channel timestamps were identical.

The same issue exists with +S/+c.
TagsNo tags attached.
3rd party modules

Activities

codemastr

2005-03-05 12:13

reporter   ~0009431

I guess we just need a precedence rule. I would suggest +s > +p and +c > +S. The rationale is, +s does everything +p does and more so +s is "stronger." And, +c is stronger than +S because +S strips the color codes whereas +c actually blocks the text.

syzop

2005-03-05 13:06

administrator   ~0009434

yeah, sounds good.

shall I take a look at this? or are you working on it :).

syzop

2005-03-05 15:46

administrator   ~0009439

Last edited: 2005-03-05 15:47

Fixed in .326

Oh, note that the message can look a bit weird... you will see for example:
-p+s on BOTH sides, so also the side that was already +s (and never +p)... but ah well, you should be able to live with that.. the alternative isn't much better and even more ugly to code :P.

Issue History

Date Modified Username Field Change
2005-03-05 04:59 Ron2K New Issue
2005-03-05 11:36 syzop Status new => acknowledged
2005-03-05 12:13 codemastr Note Added: 0009431
2005-03-05 13:06 syzop Note Added: 0009434
2005-03-05 15:46 syzop Status acknowledged => resolved
2005-03-05 15:46 syzop Fixed in Version => 3.2.3
2005-03-05 15:46 syzop Resolution open => fixed
2005-03-05 15:46 syzop Assigned To => syzop
2005-03-05 15:46 syzop Note Added: 0009439
2005-03-05 15:47 syzop Note Edited: 0009439
2005-03-05 15:47 syzop Note Edited: 0009439