View Issue Details

IDProjectCategoryView StatusLast Update
0002474unrealinstallingpublic2005-05-26 16:43
Reporterlion-oAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel platformOSSolaris 10/x86OS VersionSunOS 5.10
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002474: Config won't spot 'config.settings'
DescriptionIn order to read the previous settings (saved in 'config.settings) the Config script force-executes the file using '. config.settings'. On some Unix environments this won't work because the current directory is not in the PATH, automaticly resulting in:

pandora:/usr/local/src/Unreal3.2 $ ./Config -advanced
./Config: config.settings: not found

My suggestion would be to replace '. config.settings' with '. ./config.settings' in order to increase the 'out-of-the-box' portability. Its located on 2 lines only.
Steps To ReproduceCompile Unreal like normal and after having gone through this procedure try using ./Config again.
Additional Informationpandora:/usr/local/src/Unreal3.2 $ sed -e 's/\. config\.settings/\. \.\/config\.settings/g' Config
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-04-11 11:52

administrator   ~0009733

Sounds good (on a sidenote: Linux&FreeBSD don't need this regardless of path).

Just out of curiousity, does unreal run ok on your OS? :p (like no crash on /rehash etc)

pinstrate

2005-04-11 14:07

reporter   ~0009734

Yeah. Same problem occurs to me.. Running on NetBSD 2.0

lion-o

2005-04-12 14:56

reporter   ~0009737

syzop: At the moment I'm still in a test fase but so far Unreal runs like a charm in both the main Solaris zone as well as one of the non-global zones (zones are comparible with the *bsd jails or the Linux UML's). The only issue I've had so far was during compiling within a zone, but the cause isn't related to Unreal in any way.

Upcoming weekend I'm hoping to finish getting Anope & NeoStats setup after which I'm planning to give the box a few crash tests. I'm quite sure that if there are any irrgularities they'll pop up then.

lion-o

2005-05-03 13:41

reporter   ~0009888

I'm not too sure about using this environment to pass notes but since Syzop seemed interested I'll just post & keep it brief.

Syzop: I have completed the crash test but since it wasn't aimed at Unreal (actually meant to test Anope & NeoStats) I basicly let it at what it was untill I remembered this post. If you're interested you can see a small report of this test here: http://www.anope.org/postt2039.html. Unreal was running in a non-global zone as a non-priviledged user (irc).

At this moment I've taken this one step further; Unreal is now running chroot'ed in a non-global zone with its privileges set to an absolute minimum. For example; its allowed to fork() but should it fork a shell (in a compromise attempt for example) the new process won't be able to execute anything else. I am very impressed with both Solaris and Unreal in this setup, especially if you consider the fact that most IRC related software (this includes both Anope & NeoStats) is totally unable to compile let alone run on Solaris.

(For more info on Solaris' very enhanced security features see: http://www.sun.com/software/solaris/utilization.jsp).

syzop

2005-05-07 00:48

administrator   ~0009894

Hm I thought I posted a reaction a few days ago, but I guess I closed my browser ;).

Anyway, what it came down to is that if you, lion-o, experienced any issues with unreal then I suggest opening up a new bugreport (I must admit I didn't read your whole post), if not then.. good! ;)

[OFFTOPIC]
Personally I use Linux w/grsecurity w/RBAC.. I think that's just as safe (or even safer) than the solaris stuff but it's more work to configure I think... but: I can't compare :).
I'll probably take a look myself somewhere in the next few months at Solaris 10.. sounds like a decent OS (and it's free), so worth to expand my knowledge on that. Thanks for the tip.
[/OFFTOPIC]

syzop

2005-05-26 16:42

administrator   ~0009996

Fixed in CVS .351.

Issue History

Date Modified Username Field Change
2005-04-11 11:42 lion-o New Issue
2005-04-11 11:52 syzop Note Added: 0009733
2005-04-11 14:07 pinstrate Note Added: 0009734
2005-04-11 14:11 syzop Status new => acknowledged
2005-04-12 14:56 lion-o Note Added: 0009737
2005-05-03 13:41 lion-o Note Added: 0009888
2005-05-07 00:48 syzop Note Added: 0009894
2005-05-26 16:42 syzop Status acknowledged => resolved
2005-05-26 16:42 syzop Fixed in Version => 3.2.4
2005-05-26 16:42 syzop Resolution open => fixed
2005-05-26 16:42 syzop Assigned To => syzop
2005-05-26 16:42 syzop Note Added: 0009996