View Issue Details

IDProjectCategoryView StatusLast Update
0002478unrealircdpublic2006-11-12 14:32
ReporterWhite_MagicAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.6 
Summary0002478: Usermode to stop /invites being recieved
Descriptionbotnet decides to do /invite on me eariler
so i got a nice 200 invite flood to there room on a network im not ircop on and there is only 2 netadmins and 5 globals (which are hardly there)
sure i ignored *!*@* for invites with my script but not all have mirc, i think a umode should be made to block them.. (with the exception of services/IRCOPS)
-
since you can use /invite without ops it can be floody, some form of protection is needed for users that are on java/webtv etc etc
TagsNo tags attached.
3rd party modules

Activities

codemastr

2005-04-12 23:02

reporter   ~0009738

I don't really like the idea of a "no invite" mode, it seems very wasteful. A better solution might be to have /silence ignore invites.

White_Magic

2005-04-13 09:48

reporter   ~0009742

is this working right now or can it be added?

codemastr

2005-04-13 23:47

reporter   ~0009748

No it's not working now, I was talking about adding it.

White_Magic

2005-04-16 12:50

reporter   ~0009761

okie then yes i agree with your idea on adding it

syzop

2006-11-12 14:32

administrator   ~0012640

Done so in 32* and 33*:
- /INVITE's from people on the silence list are now (silently) ignored, suggested by
  White_Magic (0002478).

Issue History

Date Modified Username Field Change
2005-04-12 21:49 White_Magic New Issue
2005-04-12 23:02 codemastr Note Added: 0009738
2005-04-13 09:48 White_Magic Note Added: 0009742
2005-04-13 23:47 codemastr Note Added: 0009748
2005-04-16 12:50 White_Magic Note Added: 0009761
2006-11-12 14:32 syzop Status new => resolved
2006-11-12 14:32 syzop Fixed in Version => 3.2.6
2006-11-12 14:32 syzop Resolution open => fixed
2006-11-12 14:32 syzop Assigned To => syzop
2006-11-12 14:32 syzop Note Added: 0012640