View Issue Details

IDProjectCategoryView StatusLast Update
0002482unrealircdpublic2005-11-14 14:10
ReporterendrjuAssigned Tosyzop 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSOpenBSDOS Version3.7
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002482: [OpenBSD] A /rehash kills the ircd
DescriptionWhen you're trying to rehash, ircd server crashes.
Additional Information# gdb ircd ircd.core
GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-unknown-openbsd3.7"...
Core was generated by `ircd'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libssl.so.9.0...done.
Loaded symbols for /usr/lib/libssl.so.9.0
Reading symbols from /usr/lib/libcrypto.so.11.0...done.
Loaded symbols for /usr/lib/libcrypto.so.11.0
Reading symbols from /usr/lib/libz.so.4.0...done.
Loaded symbols for /usr/lib/libz.so.4.0
Reading symbols from /usr/lib/libc.so.35.0...done.
Loaded symbols for /usr/lib/libc.so.35.0
Reading symbols from /usr/libexec/ld.so...done.
Loaded symbols for /usr/libexec/ld.so
#0 0x00000000 in ?? ()
(gdb) bt
#0 0x00000000 in ?? ()
#1 0x1c017f7b in Init_all_testing_modules () at modules.c:460
#2 0x1c02357e in init_conf (rootconf=0x3c000d93 "unrealircd.conf", rehash=1) at s_conf.c:1648
#3 0x1c031bfc in rehash_internal (cptr=0x3c0b1420, sptr=0x3c0b1420, sig=1) at s_conf.c:8679
#4 0x1c0161de in main (argc=0, argv=0xcfbbeff8) at ircd.c:1588
(gdb) quit
TagsNo tags attached.
3rd party modules

Relationships

related to 0002490 closed /rehash segfaults ircd 

Activities

endrju

2005-04-13 16:32

reporter   ~0009743

Sorry, I accidentally choose "documentation" category and I don't know how to change it.

syzop

2005-04-13 16:33

administrator   ~0009744

any 3rd party modules? (so any other module besides cloak.so and commands.so)

OpenBSD used to crash on /REHASH due to their buggy dl*() implementation, this seemed fixed however in 3.5.

endrju

2005-04-13 16:36

reporter   ~0009745

No, just cloak.so and commands.so. Actually, it's very default setup.

OpenBSD-current (3.7), so 3.5 is far behind :)

syzop

2005-04-13 16:40

administrator   ~0009746

Just for reference, line 460 is:
            if ((ret = (*Mod_Init)(&mi->modinfo)) < MOD_SUCCESS) {
so Mod_Init is apparantly NULL

This is "impossible", I really hope it's not another OpenBSD issue... I thought it ran ok on 3.7.

endrju

2005-04-13 17:09

reporter   ~0009747

OpenBSD 3.7 is still just -current and it will become a release in May 19 (that's the official statement, tough).

I recheked - it's really that line. Sad.

Maybe I can try to update source from CVS and rebuild? Which branch do I have to use (I've never updated UnrealIRCd source from CVS)? Or I must do like FAQ "Other - What's CVS and where to get CVS versions?" says?

endrju

2005-04-14 05:38

reporter   ~0009750

I tried CVS stable and devel version; I tried to build source with different options; I even tried to downgrade OpenBSD to stable (not -current), but result always is exacly the same (modules.c:460). Any suggestions?

syzop

2005-04-14 09:11

administrator   ~0009751

Not really... if it's similar like the previous openbsd issue then it would mean we would have to debug for hours and hours on OpenBSD. Currently, I'm not really in the mood to do that again.. especially since last time both me+code worked on it like 10h total and it turned out it wasn't our fault.
But hey, who knows one of us gets a real urge to fix this in a few weeks :).

I'll remove your core file from from the attachement so we can mark the bug public again.

endrju

2005-04-15 03:20

reporter   ~0009754

Yawn, lot of debugging and I'm not in mood/free-time right now, too. Sooner or later urge to fix this, as you said, gets somebody ;)

Unfortunately I'm out of time, that's why I will install other BSD for now and when this will be fixed I'll just step to OpenBSD, again.

Thanks for your responsiveness;

b1

2005-07-08 19:23

reporter   ~0010215

Any updates on this issue, I am having the same problem but would rather not change OS. I notice this issue was related to 2490 but that was closed due to compile options, are there any different compile option sI should use for OpenBSD?

syzop

2005-07-25 19:50

administrator   ~0010258

Could one of you give me an openbsd account so I can try to play around a bit with this (no guarantees whatsoever)? syzop@unrealircd.com

Software I would like to be installed (so you can prepare a bit already):
- joe (an editor)
- gcc, make, etc (naturally)
- gdb (naturally)
- strace (or truss, or whatever)
- ltrace (if that exists for openbsd?)
- objdump, ldd, etc (should be include in a basic system install already, but just in case..)
That's all I can think of right now :).

syzop

2005-08-19 12:03

administrator   ~0010357

Just for everyone's information... I have received 0 temporary openbsd account offers :p.

syzop

2005-11-14 14:10

administrator   ~0010742

This was fixed 9 days ago in CVS:

- Fixed OpenBSD crash on /REHASH. Thanks to Peter Laur (OpenBSD.se) for providing us
  a shell account to trace this issue down.

Issue History

Date Modified Username Field Change
2005-04-13 16:24 endrju New Issue
2005-04-13 16:24 endrju File Added: ircd.core.zip
2005-04-13 16:30 syzop View Status public => private
2005-04-13 16:32 endrju Note Added: 0009743
2005-04-13 16:33 syzop Note Added: 0009744
2005-04-13 16:33 syzop Category documentation => ircd
2005-04-13 16:36 endrju Note Added: 0009745
2005-04-13 16:40 syzop Note Added: 0009746
2005-04-13 17:09 endrju Note Added: 0009747
2005-04-14 05:38 endrju Note Added: 0009750
2005-04-14 09:11 syzop Note Added: 0009751
2005-04-14 09:11 syzop File Deleted: ircd.core.zip
2005-04-14 09:11 syzop View Status private => public
2005-04-15 03:20 endrju Note Added: 0009754
2005-04-16 00:29 syzop Summary "./unreal rehash" in console or "/rehash" as Oper crashes ircd => [OpenBSD] A /rehash kills the ircd
2005-04-21 08:34 syzop Relationship added related to 0002490
2005-07-08 19:23 b1 Note Added: 0010215
2005-07-25 19:50 syzop Note Added: 0010258
2005-08-19 12:03 syzop Note Added: 0010357
2005-11-14 14:10 syzop Status new => resolved
2005-11-14 14:10 syzop Fixed in Version => 3.2.4
2005-11-14 14:10 syzop Resolution open => fixed
2005-11-14 14:10 syzop Assigned To => syzop
2005-11-14 14:10 syzop Note Added: 0010742