View Issue Details

IDProjectCategoryView StatusLast Update
0002496unrealircdpublic2005-12-09 15:24
ReporterHomerAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.4 
Summary0002496: Spamfilter 'p' should match messages send via aliases (/ns, /cs, etc)
DescriptionSome users use aliases for sending unauthorized messages to the services and set these messages to entrymsg or greet messages.

Example:

- I add this spamfilter : /spamfilter add p block - - Test123
- /msg testnick Test123 = Message to testnick blocked: default reason
- /ns set greet Test123 = allowed, but should not :)
Additional InformationI put this bug private, I don't think this is a good idea that many users know how to abuse of the spamfilter command.
TagsNo tags attached.
3rd party modules

Activities

Homer

2005-05-09 01:34

reporter   ~0009906

Anyone? Good or bad idea? :)

codemastr

2005-05-13 01:31

reporter   ~0009941

Well, there are other things to consider here. For example, what if my nickserv password has some of those words in it? You'll also notice that +G has no effect when sending to services for this very reason...

Homer

2005-05-13 11:21

reporter   ~0009942

Hum.. good point. I didn't think to that..

tabrisnet

2005-06-04 20:06

reporter   ~0010029

Well, what I've been having is users that come to my network and then say do a SPAM for animelab, or rizon... or the 'network of the week' that their friend started.

We find out and set a spamfilter for it, usually block or kill. if a user repeatedly triggers the filter they get a temp gline.

This bug however means that users can just use /ms send dumbass Hey, join my crappy network! /server -m irc.idiots.net -j #fuckwads

I know that this means that there are actual humans doing this, and not bots... and we do tend to not block certain networks. We only set a spamfilter if we have caught people SPAMming it vs just talking about the network.

If you think that it should not be part of hte 'p' target, perhaps add a 'l' for 'alias' target. Honestly, I thought that /ns was just an alias for PRIVMSG NickServ so should be filtered anyway. It shouldn't be that much of a special case.

and if we have users setting passwords or something that trigger on spamfilters, i don't see that as being an issue either. If the user can't trust the opers to see their password, they're scrod anyway. it's just a getpass away.

Stealth

2005-06-04 22:10

reporter   ~0010031

I kind of like this idea, but it should be done with a new type, if done at all. The reason for that is because you probably don't want ALL your spamgilters going through, but only some. Some services need to allow users to set their email address, and also services have places to set things like a website and such...

codemastr

2005-06-05 12:37

reporter   ~0010034

I'll admit, I never thought of MemoServ. That's a good point. Perhaps the best way to deal with this is to have some kind of option that lets you set whether it is filtered or not.

aquanight

2005-06-05 17:07

reporter   ~0010042

That... or... get... a... MemoServ... that... filters... too...

*Adds a ms_spamfilter anope module to his list of things to do.*

tabrisnet

2005-06-05 17:41

reporter   ~0010043

And to think that I was working on a system to eliminate external programs to do filtering (namely I wrote a SecureServ definition to SpamFilter converter).

I guess I could stick a regexp check into my MemoServ. iterate over a list of regexp checks.

Anyway, I feel like this is the wrong solution.

syzop

2005-12-08 19:42

administrator   ~0010833

Last edited: 2005-12-08 19:43

Technically implemented (on my machine), the way codemastr said.. as an per-alias option.
I'll probably enable filtering by default for /MS and /MEMOSERV in aliases/*.conf, since that seems a good suggestion (thanks tabrisnet).

Only thing left is to update docs, make sure it works fully for all alias types, and then commit.. Will probably do so Friday or Saturday.

EDIT: /MEMOSERV too

syzop

2005-12-09 15:24

administrator   ~0010836

Added in .402.

Changelog follows.

- Added option to apply spamfilters to aliases as well (such as /MS, etc). To do so,
  you have to put 'spamfilter yes;' in every alias block you want to get filtered.
  This is so you can have for example /MS filtered (due to heavy spam), while keeping
  /NS and /CS unfiltered. Reported by Homer (0002496).
- The memoserv aliases (/MS and /MEMOSERV) now have spamfiltering enabled by default.

Issue History

Date Modified Username Field Change
2005-04-23 19:20 Homer New Issue
2005-05-09 01:34 Homer Note Added: 0009906
2005-05-13 01:31 codemastr Note Added: 0009941
2005-05-13 11:21 Homer Note Added: 0009942
2005-06-04 19:48 syzop View Status private => public
2005-06-04 20:06 tabrisnet Note Added: 0010029
2005-06-04 22:10 Stealth Note Added: 0010031
2005-06-05 12:37 codemastr Note Added: 0010034
2005-06-05 17:07 aquanight Note Added: 0010042
2005-06-05 17:41 tabrisnet Note Added: 0010043
2005-12-08 19:35 syzop Status new => assigned
2005-12-08 19:42 syzop Note Added: 0010833
2005-12-08 19:43 syzop Note Edited: 0010833
2005-12-09 15:24 syzop Status assigned => resolved
2005-12-09 15:24 syzop Fixed in Version => 3.2.4
2005-12-09 15:24 syzop Resolution open => fixed
2005-12-09 15:24 syzop Assigned To => syzop
2005-12-09 15:24 syzop Note Added: 0010836