View Issue Details

IDProjectCategoryView StatusLast Update
0002508unrealircdpublic2005-05-26 16:48
ReporterRon2KAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindows XP ProOS VersionSP2
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002508: Wierd results with +I and set::modes-on-join
DescriptionWhile going through the documentation in search of something, I noticed that part of the documentation for set::modes-on-join states "Not all modes can be set using this command. +qaohvbeOAzlLk can NOT be set using this command". Having a look at those modes that cannot be set, I noticed that they're all the modes that either require an additional parameter (ie q,b,e,l) and modes that restrict access in some way (O,A,z). Then I thought: if +b and +e is in there, why not +I? (They all take the same parameter format, that of nick!user@host.)

Anyway, I decided to see what would happen if I added +I to set::modes-on-join. The configuration that I used to test this was:

set {
     modes-on-join "+I *!*@*.test.net";
};

Not only did the IRCd fail to complain about +I being in set::modes-on-join (which I feel it should have), but joining a channel afterwards produced some pretty wierd results; the relevant parts of the raw log follows:

<< JOIN #test
>> :Ron2K!Ron2K@netadmin.langames.net JOIN :#test
<< MODE #test
<< WHO #test
>> :ron2k.langames.net MODE #test +I
>> :ron2k.langames.net 353 Ron2K = #test :@Ron2K
>> :ron2k.langames.net 366 Ron2K #test :End of /NAMES list.
>> :ron2k.langames.net 324 Ron2K #test +I
....
>> :ron2k.langames.net 315 Ron2K #test :End of /WHO list.

Notice the absence of "*!*@*.test.net".

The solution should be to stop +I from being used in set::modes-on-join.
TagsNo tags attached.
3rd party modules

Activities

Stealth

2005-04-30 17:14

reporter   ~0009867

I believe set::modes-on-join wont take any mode that requires a parameter, because it was not designed for modes with parameters.

Although, if Unreal isnt ignoring the +I and setting it without a parameter, then it is a small bug.

syzop

2005-05-26 16:48

administrator   ~0009999

Fixed in CVS .352

Issue History

Date Modified Username Field Change
2005-04-30 04:08 Ron2K New Issue
2005-04-30 17:14 Stealth Note Added: 0009867
2005-05-26 16:48 syzop Status new => resolved
2005-05-26 16:48 syzop Fixed in Version => 3.2.4
2005-05-26 16:48 syzop Resolution open => fixed
2005-05-26 16:48 syzop Assigned To => syzop
2005-05-26 16:48 syzop Note Added: 0009999