View Issue Details

IDProjectCategoryView StatusLast Update
0002511unrealircdpublic2006-01-16 17:05
ReporterKnuXAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002511: Modify the channel bans limit without editing sources
DescriptionSometimes, it may be needed to increase the number of bans we can put on a channel (example: 100 instead of 60, the current value).

On the forum, a moderator reply me that I have to edit source files without any indication. In addition, I know about the support of edited files...

Is it possible to specify this value during the ./Config script or in another way without having to modify a file and to lose your support ?

I sincerly need to increase the MAXLIMIT value, and I'm not sure to be alone in this situation ;)

Thanks you in advance :)
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-05-02 17:24

administrator   ~0009883

Perhaps in the future some settings will be more dynamic, but for now:

You got permission from me (w00 ;p) to modify the following 2 values in struct.h:
MAXBANS and MAXBANLENGTH
Note that you should not modify any other settings because doing so (for most) is dangerous, causes incompatability, (possible) crashes, etc.
MAXBANS and MAXBANLENGTH are safe to modify however.

Example: put MAXBANS at 100 and MAXBANLENGTH at 2048 or 4096 (yes, IMO the default MAXBANLENGTH is a bit too low).

MAXBANLENGTH is the total stringsize of all bans in the channel added up together btw.

I did suggest this for ./Config -advanced, but apparantly it got forgotten or something.

Stealth

2005-05-02 23:15

reporter   ~0009885

I think it should be in ./Config -adavnced.

aquanight

2005-05-03 02:18

reporter   ~0009886

I wonder if MAXBANLENGTH should just be calculated from MAXBANS*(NICKLEN+USERLEN+HOSTLEN+2)? In theory that should be about enough for any ban list :P .

syzop

2005-05-03 10:11

administrator   ~0009887

Bugz: that's exactly what I said
aquanight: no, then you can just as easily remove it, you are missing the purpose.

w00t

2005-05-12 20:27

reporter   ~0009939

The purpose (if i remember rightly) is to stop bans using too much memory?

syzop

2006-01-16 17:05

administrator   ~0010971

Added in .419

Issue History

Date Modified Username Field Change
2005-05-02 16:15 KnuX New Issue
2005-05-02 17:24 syzop Note Added: 0009883
2005-05-02 23:15 Stealth Note Added: 0009885
2005-05-03 02:18 aquanight Note Added: 0009886
2005-05-03 10:11 syzop Note Added: 0009887
2005-05-12 20:27 w00t Note Added: 0009939
2006-01-16 17:05 syzop Status new => resolved
2006-01-16 17:05 syzop Fixed in Version => 3.2.4
2006-01-16 17:05 syzop Resolution open => fixed
2006-01-16 17:05 syzop Assigned To => syzop
2006-01-16 17:05 syzop Note Added: 0010971