View Issue Details

IDProjectCategoryView StatusLast Update
0002577unrealinstallingpublic2005-08-29 17:57
ReporterTheEggManAssigned Tocodemastr 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSWin32OS Version.net 2003
Product Version3.2.4 
Target VersionFixed in Version3.2.4 
Summary0002577: Current CVS does not compile with vs.net 2003
Descriptionwircd.def : error LNK2001: unresolved external symbol parse_tkl_para
wircd.def : error LNK2001: unresolved external symbol target_is_spamexcept
wircd.lib : fatal error LNK1120: 2 unresolved externals
LINK : fatal error LNK1141: failure during build of exports file
NMAKE : fatal error U1077: 'link' : return code '0x475'
Stop.

Get this at first, when I rebuild the wircd.def I get this:
   Creating library L_COMMANDS.lib and object L_COMMANDS.exp
M_TKL.obj : error LNK2019: unresolved external symbol _regfree referenced in function __tkl_del_line
M_TKL.obj : error LNK2019: unresolved external symbol _regexec referenced in function __dospamfilter
src/modules/commands.dll : fatal error LNK1120: 2 unresolved externals
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.
Steps To Reproduceclean cvs checkout
nmake -f makefile.win32
nmake -f makefile.win32 SYMBOLFILE
nmake -f makefile.win32
TagsNo tags attached.
3rd party modulesn/a

Activities

syzop

2005-08-19 11:53

administrator   ~0010353

codemastr, could you help out with this? I don't know how to fix this...

codemastr

2005-08-19 14:15

reporter   ~0010362

I got it working, but the CVS machine seems down at the moment. Basically, since your moving functions to module stuff, commands.so and m_tkl.so now have a dependency on TRE so I just told it to link with TRE and it worked. As soon as CVS is back I'll commit.

codemastr

2005-08-19 14:22

reporter   ~0010365

Fixed in .370

syzop

2005-08-19 18:34

administrator   ~0010375

hm, did you commit this?
Because I still get the same compile problem on win32

(btw, we are talking about windows here, or at least I haven't seen *NIX people with problems).

codemastr

2005-08-20 00:24

reporter   ~0010376

Yeah I was referring to Windows, though I have VS.NET 2002, not 2003. After changing the Makefile.win32, it works fine here now.

codemastr

2005-08-20 00:31

reporter   ~0010377

Hmm, wait a minute. I know I *did* commit this but now looking at it, it isn't committed! I'll do it again tomorrow (the files are on a different pc)

syzop

2005-08-29 17:57

administrator   ~0010419

In either case.. it should be fixed now (committed) in .379.

Issue History

Date Modified Username Field Change
2005-06-29 20:12 TheEggMan New Issue
2005-06-29 20:12 TheEggMan 3rd party modules => n/a
2005-07-22 20:36 syzop Status new => confirmed
2005-08-19 11:53 syzop Note Added: 0010353
2005-08-19 14:15 codemastr Note Added: 0010362
2005-08-19 14:22 codemastr Status confirmed => resolved
2005-08-19 14:22 codemastr Resolution open => fixed
2005-08-19 14:22 codemastr Assigned To => codemastr
2005-08-19 14:22 codemastr Note Added: 0010365
2005-08-19 18:34 syzop Note Added: 0010375
2005-08-19 18:35 syzop Status resolved => confirmed
2005-08-19 18:35 syzop Resolution fixed => open
2005-08-19 18:35 syzop Additional Information Updated
2005-08-20 00:24 codemastr Note Added: 0010376
2005-08-20 00:31 codemastr Note Added: 0010377
2005-08-29 17:57 syzop Status confirmed => resolved
2005-08-29 17:57 syzop Fixed in Version => 3.2.4
2005-08-29 17:57 syzop Resolution open => fixed
2005-08-29 17:57 syzop Note Added: 0010419