View Issue Details

IDProjectCategoryView StatusLast Update
0002581unrealircdpublic2006-05-19 06:51
ReporterKnAseNAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformOSWindowsOS VersionXP
Product Version3.2.3 
Target VersionFixed in Version3.2.5 
Summary0002581: [BUG] operator count bug!
Description[Tue Jun 28 16:02:56 2005] - [BUG] operator count bug! value in /lusers is '-1', we counted '1', user='sandra_kvinnan', userserver='irc.SadisticNet.org', tag=umode1. please report to UnrealIRCd team at http://bugs.unrealircd.org/
TagsNo tags attached.
3rd party modules

Relationships

related to 0002633 closed Operator Count Bug! 
related to 0002628 closed OperCount Error 
related to 0002414 closed [BUG] operator count bug 
related to 0001595 closed [BUG] operator count bug 
related to 0001352 closed operator count bug (recent cvs) 
child of 0002748 closedsyzop 3.2.5 Release 

Activities

syzop

2005-07-03 16:53

administrator   ~0010161

Thanks.
What services are you using? And with any modules?

KnAseN

2005-07-03 17:04

reporter   ~0010162

i have not been running service during that time but with some modules:
m_ircops
m_staff
m_regexcept
m_nocodes
m_privdeaf
topicbadwords
m_getinfo

syzop

2006-05-18 17:13

administrator   ~0011732

I might have traced one of the causes of this.
If you are oper and +H, and you do "/mode nick -oH" (or -Ho), then this bug appears.

pinstrate

2006-05-19 00:28

reporter   ~0011733

no. This happens when the server is nearly empty and there are no opers on int at all.

syzop

2006-05-19 06:21

administrator   ~0011734

Last edited: 2006-05-19 06:24

Actually, the message is delayed until the opercount reaches -1, only THEN it goes check things :P.
This is why it can happen days after the actual bug happened.

EDIT: services servers can still trigger the bug in other ways, but this bug I talked about can happen regardless of services and is a clear error on our part.

pinstrate

2006-05-19 06:24

reporter   ~0011735

ok, then how would you explain why it happens on a server where are no o-lines in the config file at all?

syzop

2006-05-19 06:27

administrator   ~0011736

no olines? how do you oper up then?

syzop

2006-05-19 06:35

administrator   ~0011737

The ircd.log snippet, is that from the same server as mentioned in serserver='irc.SadisticNet.org' or not?

pinstrate

2006-05-19 06:41

reporter   ~0011738

anyway. There was a period (about 6 months) when one of our server (formerly running unrealircd) had no operators. It was configured properly and managed via a shell access, so it had no o-lines during the period when no one (except me) was responsible for it. Then I saw those messages in the logfile.. If my memory is still good, I'd say it was 3.2.2b-3.2.3 times..

syzop

2006-05-19 06:46

administrator   ~0011739

oh KnAseN != you :P

Anyway, no problem if you don't have details anymore, I realize the reports are old (after all, other bugs have higher priority than oper counts, plus this bug is hard to trace down).
I'm going to fix this bug (commit in a second), which hopefully fixes all bugs on our part. We'll see if people still have problems after 3.2.5.. ;P

syzop

2006-05-19 06:51

administrator   ~0011740

This non-services operator count bug is now fixed in CVS .505:

- Fixed oper count bug which happened on /mode, this was our fault (can't blame services in
  this case ;p). Reported by KnAseN and many others (0002581).
  There might still be other operator count bugs, but these are triggered by a different bug
  and may or may not be caused by services.

Issue History

Date Modified Username Field Change
2005-07-03 16:51 KnAseN New Issue
2005-07-03 16:53 syzop Note Added: 0010161
2005-07-03 17:04 KnAseN Note Added: 0010162
2006-05-18 17:11 syzop Relationship added related to 0002633
2006-05-18 17:11 syzop Relationship added related to 0002628
2006-05-18 17:11 syzop Relationship added related to 0002141
2006-05-18 17:12 syzop Relationship deleted related to 0002141
2006-05-18 17:12 syzop Relationship added related to 0002414
2006-05-18 17:12 syzop Relationship added related to 0001595
2006-05-18 17:12 syzop Relationship added related to 0001352
2006-05-18 17:13 syzop Note Added: 0011732
2006-05-18 17:14 syzop Relationship added child of 0002748
2006-05-19 00:28 pinstrate Note Added: 0011733
2006-05-19 06:21 syzop Note Added: 0011734
2006-05-19 06:24 syzop Note Edited: 0011734
2006-05-19 06:24 pinstrate Note Added: 0011735
2006-05-19 06:27 syzop Note Added: 0011736
2006-05-19 06:35 syzop Note Added: 0011737
2006-05-19 06:41 pinstrate Note Added: 0011738
2006-05-19 06:46 syzop Note Added: 0011739
2006-05-19 06:51 syzop Status new => resolved
2006-05-19 06:51 syzop Fixed in Version => 3.2.5
2006-05-19 06:51 syzop Resolution open => fixed
2006-05-19 06:51 syzop Assigned To => syzop
2006-05-19 06:51 syzop Note Added: 0011740