View Issue Details

IDProjectCategoryView StatusLast Update
0002602unrealircdpublic2015-05-30 15:29
ReporterpinstrateAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformOSanyOS Versionany
Product Version3.2.4 
Target VersionFixed in Version3.4-alpha3 
Summary0002602: Some feature suggests for Unreal 3.3*
DescriptionIt would be great for Unreal 3.3* if:
* /rehash -dns could rehash the whole dns system (w/o restart): rereal /etc/resolv.conf, apply the new nameserver(s), flush cache and etc..
* more stuff would be modulized: let's say if i don't want to have a 'foo' feature, I just remove that module and that's all. No need to think, modify source and etc..

any my offtopic opinion: also it would be nice it Unreal would become a more serious ircd ;) I mean, no such stuff like bot* (botmode, botmotd and etc) and other, which most people don't use :)

BTW: good luck in 3.3* developement!
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-07-27 14:55

administrator   ~0010270

I fail to see why the bot* stuff would be not serious... IMO it's a good way to distinct bots from normal users, I can imagine some networks even enforcing rules such as that bots should be always +B and stuff like that.

dns.. yeah

modulizing.. well, in many cases it only makes the code more comlicated.. like modlizing operoverride to name something, in such cases it is better if it is a simple setting. But if you want to simply rip out a command, then that is already possible (load the m_*.so individually instead of commands.so, and rename/delete the command you want to get rid of). Although perhaps a config item could be added. (That said, I *hate* those people who disable LUSERS, NAMES, etc "for security" in which case 99% of these people are in fact running zombie servers).
You are free to suggest additional possible settings though, like to disable certain things or make them behave differently (so.. basically, be a bit more concrete)

Something else I thought of though: I think it's a good idea to have something like ::disable-usermodes and ::disable-chanmodes... the difference with ::restrict-* would be that they are really disabled in a sense that not even opers or services can set them anymore.

Stealth

2005-07-27 16:03

reporter   ~0010271

I like the disable chan/usermodes, it is a good idea

aquanight

2005-07-28 00:55

reporter   ~0010272

I had thought about suggesting a disable-like thing once... :)

codemastr

2005-08-15 14:50

reporter   ~0010339

[quote]any my offtopic opinion: also it would be nice it Unreal would become a more serious ircd ;) I mean, no such stuff like bot* (botmode, botmotd and etc) and other, which most people don't use :)[/quote]
Just because most people don't use it doesn't mean it should be removed. The people who do use it obviously like it. Also, just because something isn't frequently used doesn't make the IRCd "less serious."

syzop

2015-05-30 15:28

administrator   ~0018378

Done in 3.4.x alpha's

Issue History

Date Modified Username Field Change
2005-07-27 14:45 pinstrate New Issue
2005-07-27 14:55 syzop Note Added: 0010270
2005-07-27 16:03 Stealth Note Added: 0010271
2005-07-28 00:55 aquanight Note Added: 0010272
2005-08-15 14:50 codemastr Note Added: 0010339
2007-04-27 04:08 stskeeps Status new => acknowledged
2015-05-30 15:28 syzop Note Added: 0018378
2015-05-30 15:28 syzop Status acknowledged => closed
2015-05-30 15:29 syzop Assigned To => syzop
2015-05-30 15:29 syzop Resolution open => fixed
2015-05-30 15:29 syzop Fixed in Version => 3.4-alpha3