View Issue Details

IDProjectCategoryView StatusLast Update
0002605unrealircdpublic2005-08-19 11:47
ReporterPhantasyXAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSFreeBSDOS Versionxx
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002605: +b ~c: not-allowing certain bans
Description(Sorry for OS version; unable to locate owner)

You can have channels named #*
If you /mode #channel +b ~c:#* to ban users that are in that are in that channel it adds the ban.
But if you try to /mode #channel +b ~c:#other-channel it wont' add the ban.
When the ~c:#* is removed you can add other channels.
Steps To Reproduce/mode #channel +b ~c:#*
/mode #channel +b ~c:#other-channel
/mode #channel -b ~c:#*
/mode #channel +b ~c:#other-channel
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-07-29 17:49

administrator   ~0010285

Last edited: 2005-07-29 17:50

Most likely (although I didn't test it) escaping would solve it:
/mode #channel +b ~c:#\*

EDIT: hmm or actually it might well not match then anymore *g* ;).

Stealth

2005-07-29 18:26

reporter   ~0010286

Perhaps ~c bans should be taken litterally? If escaping is implimented into ~c bans, it can be quite messy since most users don't know how to escape characters (like escaping \ * and ?)

White_Magic

2005-07-30 10:37

reporter   ~0010293

i did some quick testing with a ircop,

#* seems to ban every channel, as she couldnt join the room i was in when i banned ~c:#* - she wasnt in the room " #* " but she still couldnt join

#\* = only bans u if ur in the room " #\* "
 when she parted she could join my room

syzop

2005-08-19 11:47

administrator   ~0010351

Fixed in CVS .386:

- Fixed ~c not working properly with * and ?'s in channel names.. Now you just need to
  escape them like in all bans (eg: to ban #* you need to +b ~c:#\*). As an additional
  bonus, real wildcards are now accepted and processed (eg: +b ~c:#*sex*, just don't
  forget to specify the #). Reported by PhantasyX (0002605).
- Sidenote on above: ~c:*chan* is not supported (use ~c:#*chan* instead) because it would
  cause "hidden bans", therefore it now prints a message (which is useful anyway), but
  does accept such remote bans. In 3.2.5 or so we could enable support for it, it's
  not that important though... ;)

Issue History

Date Modified Username Field Change
2005-07-29 17:47 PhantasyX New Issue
2005-07-29 17:49 syzop Note Added: 0010285
2005-07-29 17:50 syzop Note Edited: 0010285
2005-07-29 18:26 Stealth Note Added: 0010286
2005-07-30 10:37 White_Magic Note Added: 0010293
2005-08-19 11:47 syzop Status new => resolved
2005-08-19 11:47 syzop Fixed in Version => 3.2.4
2005-08-19 11:47 syzop Resolution open => fixed
2005-08-19 11:47 syzop Assigned To => syzop
2005-08-19 11:47 syzop Note Added: 0010351