View Issue Details

IDProjectCategoryView StatusLast Update
0002632unrealircdpublic2005-09-28 18:18
ReporterGilouAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSLinuxOS Version2.6.8
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002632: Document deaf mode privmsg escaping feature, and use a better default?
DescriptionEven if someone is in deaf mode (umode +d), if you send a message starting with a ` (backquote), he will see the message
Steps To Reproduce/mode Gilou +d
/join #chan

as Giloo: /msg #chan `all your base are belong to us

Gilou will see :
<Giloo> `all your base are belong to us
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-09-01 19:37

administrator   ~0010425

Last edited: 2005-09-01 19:40

set::channel-command-prefix <command-prefixes>;
Specifies the prefix characters for services "in channel commands". Messages starting with any of the specified characters will still be sent even if the client is +d. The default value is "`".


Perhaps this should be added somewhere else in the docs as well. Section 6 seems an appropriate place.

In case you wonder why it exists.. it's for bots, so they can be set +d (=save bandwidth) while still supporting triggers. I got ::channel-command-prefix set to "!." on my network (which, to be honest, seems a more reasonable default than this).

EDIT: Updated title, plus I suggest to change the default to "`.!".

Gilou

2005-09-01 19:58

reporter   ~0010426

Oops ... I have never heard of it.. Great :)
"it's not a bug, it's a feature" coming to Unreal, huh.

Stealth

2005-09-01 20:58

reporter   ~0010427

Last edited: 2005-09-01 21:01

I thought only opers can use the prefix for that... Guess not.

White_Magic

2005-09-02 16:05

reporter   ~0010429

i remember codemastr telling me that this wasnt ment for users/bots and was for services only...
 * wanders off somewhere*

syzop

2005-09-02 16:11

administrator   ~0010430

Naturally it can be used for both.

Now of course, it is NOT oper only, I already described the purpose.. if it would be oper only it would make no sense...

syzop

2005-09-28 18:18

administrator   ~0010529

Documentation has been updated, and default has been changed to "`!.".

Issue History

Date Modified Username Field Change
2005-09-01 19:32 Gilou New Issue
2005-09-01 19:37 syzop Note Added: 0010425
2005-09-01 19:39 syzop Summary Deaf mode escaped by starting PRIVMSgs with ` (backquote) => Document deaf mode privmsg escaping feature, and use a better default?
2005-09-01 19:40 syzop Note Edited: 0010425
2005-09-01 19:58 Gilou Note Added: 0010426
2005-09-01 20:58 Stealth Note Added: 0010427
2005-09-01 21:01 Stealth Note Edited: 0010427
2005-09-02 16:05 White_Magic Note Added: 0010429
2005-09-02 16:11 syzop Note Added: 0010430
2005-09-28 18:18 syzop Status new => resolved
2005-09-28 18:18 syzop Fixed in Version => 3.2.4
2005-09-28 18:18 syzop Resolution open => fixed
2005-09-28 18:18 syzop Assigned To => syzop
2005-09-28 18:18 syzop Note Added: 0010529