View Issue Details

IDProjectCategoryView StatusLast Update
0002684unrealircdpublic2015-07-19 18:43
Reporterw00tAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSn/aOS Versionn/a
Product Version3.2.3 
Target VersionFixed in Version3.4-beta1 
Summary0002684: Stuff that perhaps should be moved to snomasks.
DescriptionW = Lets you see when people do a /WHOIS on you (IRC Operators only)
v = Receive infected DCC send rejection notices

And, perhaps
w = Can listen to Wallop messages
g = Can read & send to GlobOps, and LocOps

Although I'm inclined to say 'no', as that's not a notice as such.
TagsNo tags attached.
3rd party modules

Activities

pinstrate

2005-11-11 06:52

reporter   ~0010706

Last edited: 2005-11-11 07:36

I agree.

Cause these modes are used very *rarely* :)

syzop

2005-11-11 10:59

administrator   ~0010708

Last edited: 2005-11-11 11:00

You have to keep in mind that snomasks are local only.

So things like:
' W = Lets you see when people do a /WHOIS on you (IRC Operators only)'
can then not be moved to a snomask, since it would not always be triggered (eg: not by a simple /whois nick on a remote server)

v would be possible, and logical.

w (wallops) should not be moved, w is a standard RFC1459 usermode and is assumed to be like that by many clients.

g = haven't looked at.

w00t

2005-11-12 01:19

reporter   ~0010714

Yeah, I thought that about 'w'.

'g' perhaps *could* be - Hybrid uses it for callerid, for example - etc, so it's by no means standard, and as GLOBOPS is used to broadcast messages to it rather than directly checking for umode 'g' you'd be safe.

Forgot about the local only aspect :-/. So, yeah - +W will have to stay as-is.

syzop

2015-07-19 18:43

administrator   ~0018526

So here we are, 10 years later.. let's see
* +W is not an snomask in my opinion
* +v has been moved to +D snomask, yup!
* +w is wallops.. keeping as-is
* +g has been removed entirely as it served no useful purpose

Done!

Issue History

Date Modified Username Field Change
2005-11-11 05:20 w00t New Issue
2005-11-11 06:52 pinstrate Note Added: 0010706
2005-11-11 07:36 pinstrate Note Edited: 0010706
2005-11-11 10:59 syzop Note Added: 0010708
2005-11-11 11:00 syzop Note Edited: 0010708
2005-11-12 01:19 w00t Note Added: 0010714
2007-04-27 05:10 stskeeps Status new => acknowledged
2015-07-19 18:43 syzop Note Added: 0018526
2015-07-19 18:43 syzop Status acknowledged => resolved
2015-07-19 18:43 syzop Resolution open => fixed
2015-07-19 18:43 syzop Assigned To => syzop
2015-07-19 18:43 syzop Fixed in Version => 3.4-beta1