View Issue Details

IDProjectCategoryView StatusLast Update
0002724unrealircdpublic2006-01-13 19:18
ReporterBockAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002724: allow cyrillic nick (not only russian)
DescriptionIn the countries of Eastern Europe are using codepage windows-1251. In charsys.c you have support only russian lang.
Roman Parkin did a mistake, 'cos he didn't make group of "windows-1251" like "windows-1250".
Our patch add to support in nicksystem belarussian, ukrainian language. it's was a great to add group windows-1251 and all, who using this encoding can take the nick on it national language.
Steps To Reproduceadd to charsys.c group windows-1251
TagsNo tags attached.
3rd party modulesno

Activities

2005-12-23 08:33

 

charsys.c.diff (2,451 bytes)

syzop

2006-01-13 19:18

administrator   ~0010962

Added in CVS [.408], will be in 3.2.4.

Btw, I understand the synch. problem, but the reason for the list (lang1,lang2,lang3) in a group is not "useless", it is so servers with for example:
set { charsets { chinese-simp; chinese-trad; chinese-ja; }; };
and another server with:
set { charsets { chinese; }; };
will both be able to link.
Otherwise they will turn up as a mismatch.

I know currently, if you add a new language to a group, it will also cause an inconsistency, very annoying.. I hope to resolve this a few versions in the future (by making it dependent only on groups -- not individual charsets), but not now...
I've made the synching thing a warning instead of an error, but of course that doesn't help 3.2.3<->3.2.4 linking ;).
I'll be sure to mention this problem in the release notes, I was already aware of it btw, in case you wonder... ;)

Thanks for the 2 new charsets / thanks for the patch.

Issue History

Date Modified Username Field Change
2005-12-23 08:33 Bock New Issue
2005-12-23 08:33 Bock File Added: charsys.c.diff
2005-12-23 08:33 Bock 3rd party modules => no
2005-12-23 09:17 syzop Status new => acknowledged
2006-01-13 19:18 syzop Status acknowledged => resolved
2006-01-13 19:18 syzop Fixed in Version => 3.2.4
2006-01-13 19:18 syzop Resolution open => fixed
2006-01-13 19:18 syzop Assigned To => syzop
2006-01-13 19:18 syzop Note Added: 0010962