View Issue Details

IDProjectCategoryView StatusLast Update
0002728unrealircdpublic2007-04-26 09:26
ReporterJanisBAssigned Tostskeeps 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSGentoo LinuxOS Version2.6.10
Product Version3.2.3 
Target VersionFixed in Version3.3-alpha0 
Summary0002728: Channels like #:irc.someserv.net cannot be handled by services or other servers(??)
Description-ChanServ- Channel #:irc.moocows.dk registered under your nickname: Alexey
Services want put +r on chan e.t.c. (eh.. #:irc.moocows.dk is a perfectly legal name, ©Stskeeps). So, why i can't see `ChanServ sets mode: +r` ?
Btw, "/join #:blablabla" — #:blablabla Bad Channel Mask. It's correct only if #:<server_name_here> is present
With other servers
Steps To Reproduce/join #:server_name_here
TagsNo tags attached.
3rd party modules-

Relationships

child of 0003281 resolvednenolod Removal of masked channels 

Activities

syzop

2005-12-27 14:07

administrator   ~0010895

Those are channel masks. It works like this:
#somechan:<servername> only exists on <servername> and not on any other servers
#somechan:*.de only exists on all servers ending in .de and not on others
So, naturally, services won't (or should not) be able to set modes on it if they are not included in the mask (eg: services.test.net and the chan is #blah:irc.test.net).
That's the theory, at least...

In practice, channel mask channels support is broken because it is only present in few routines (=commands) and unmaintained for years. IMO it can be removed, it's not worth keeping it.

Stealth

2005-12-27 21:57

reporter   ~0010903

Would this mean that if I had #mychan:irc.server.net it would be a local channel?

vonitsanet

2006-07-30 20:12

reporter   ~0012107

..or why not create a channel like #warez:server.netname.tld - try to forbid this channel.
It will NOT work at all..

CS-Help

2006-07-31 17:43

reporter   ~0012108

me
{
    name "irc.server.net"; // Remeber to change DENYCHAN {} block too!
    info "Server.net IRCd";
    numeric 1;
};
deny channel {
    channel "*:irc.server.net";
    reason "Don't use channels, that cannot be handled with services.";
};

Worx fine for me

syzop

2006-08-18 12:57

administrator   ~0012186

Just for the record, this bug is put "on hold". I need to decide whether to remove or implement it correctly. Sorry for the confusion.

arbours

2006-08-18 13:29

reporter   ~0012187

Hi,

I am looking for unrealircd to possibly support ":" in channel name. Since usually local charname is "&" it would be nice if we could use ":" like in all ircd. so I guess all I can do is support the idea of removing this unstandars channel mask.

#4:20
#company:2006
#company:2007
etc.. many use to it

Id thank anyone to put effort into that really! \m/

syzop

2006-08-19 09:56

administrator   ~0012188

If we remove it, we won't allow ':' in channel names. This is for compatability reasons / not to cause services to freak out, and will continue to be like that for the next 3-5 years.
So I'm afraid it's not going to help you anything ;)

djGrrr

2006-08-22 17:37

reporter   ~0012211

i like the idea of using the & prefix for local channels like other ircds do, but it would be nice if it were a compile time options (./Config -advanced), and if you get rid of the current :server.name channels, then obviously it would be best to disable their use. (until maybe 3.3 ?)

since most services and other ircd specific stuff, would need to be updated for 3.3, it would only seem logical that you could make a change like this; it wouldn't cause any problems if documented in the protocol changes correctly ;p

vonitsanet

2006-08-24 10:14

reporter   ~0012227

Why we need these (:) channels anyway?
Remove it and this is the end of story:P

stskeeps

2007-04-16 12:35

reporter   ~0013462

Bump. What did we do with this?

stskeeps

2007-04-26 09:26

reporter   ~0013741

Fixed in related bug

Issue History

Date Modified Username Field Change
2005-12-27 12:48 JanisB New Issue
2005-12-27 12:48 JanisB 3rd party modules => -
2005-12-27 14:07 syzop Note Added: 0010895
2005-12-27 21:57 Stealth Note Added: 0010903
2006-07-30 20:12 vonitsanet Note Added: 0012107
2006-07-31 17:43 CS-Help Note Added: 0012108
2006-08-18 12:57 syzop Note Added: 0012186
2006-08-18 12:57 syzop Status new => feedback
2006-08-18 13:29 arbours Note Added: 0012187
2006-08-19 09:56 syzop Note Added: 0012188
2006-08-22 17:37 djGrrr Note Added: 0012211
2006-08-24 10:14 vonitsanet Note Added: 0012227
2007-04-16 12:35 stskeeps Note Added: 0013462
2007-04-18 04:57 stskeeps Relationship added child of 0003281
2007-04-18 04:58 stskeeps Status feedback => acknowledged
2007-04-26 09:26 stskeeps Status acknowledged => resolved
2007-04-26 09:26 stskeeps Fixed in Version => 3.3-alpha0
2007-04-26 09:26 stskeeps Resolution open => fixed
2007-04-26 09:26 stskeeps Assigned To => stskeeps
2007-04-26 09:26 stskeeps Note Added: 0013741