View Issue Details

IDProjectCategoryView StatusLast Update
0002762unrealircdpublic2006-01-23 19:42
ReporterTrocotronicAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD K6 32bitsOSWindows XP ProfessionalOS VersionSP2
Product Version3.2.4 
Target VersionFixed in Version3.2.4 
Summary0002762: Maxbanlength issue
DescriptionI tried to put maxbanlength to 5.
So, firstly I get [warning] unrealircd.conf:258: Duplicate set::maxbanlength directive (and it was the first time that I was using this directive).

Avoiding this warning, I made a ban a!*@* (5 chars len). Teorically, banlist is full and you cannot make another ban. But you can, too large as you want (max NICKLEN+USERNAME+HOSTNAME of course).

In general, if ban memory is full, wircd let you to put another ban.
Steps To Reproducemaxbanlenght 5
-> /mode # b a
<- mode b a!*@*
(ban memory is full)
-> /mode # b b
<- mode b b!*@*
TagsNo tags attached.
3rd party modules

Relationships

related to 0002753 resolvedsyzop set::maxsbans, set::maxbanlength report dup 
has duplicate 0002768 closed set::maxbans taking an invalid value and working. 
has duplicate 0002769 closed set::maxbans taking a valid value, but not using it 

Activities

syzop

2006-01-23 15:43

administrator   ~0011033

Last edited: 2006-01-23 15:43

Done in .430 / will be in pre2:

- Made set::maxbanlength also count the "to be set" ban in, otherwise you could exceed the
  limit by (max) NICKLEN+USERNAME+HOSTNAME+2, reported by Trocotronic (0002762).

(oh and the duplicate thing was a dup, also just fixed)

Trocotronic

2006-01-23 19:33

reporter   ~0011040

On the pre2,
"so don't be surprised if - when it is set to 0 - you can simply set no bans"

Try to set to 0. You can add one ban.
maxbanlength 0;
<- mode # b aaaaaaaaaaaaaaaaaaaaaa
-> mode #chan +b *aaaaaaaaaaaaaaaaaaaaaaaaaaaaa!*@*

Moreover, you can always add one ban for first time, even if there is no enough length. It doesn't matter what value you set, you can add one ban at least.

syzop

2006-01-23 19:37

administrator   ~0011041

Ok, thanks, I'll fix that next RC, nothing too serious ;p.

syzop

2006-01-23 19:42

administrator   ~0011042

Fixed in .435 / will be in 3.2.4-rc1 (or pre3..)

- Made it so a set::maxbanlength and/or set::maxbans of 0 denies all bans properly, and
  fixes the first-ban-can-be-as-long-as-you-want bug, both reported by Trocotronic (0002762).

Issue History

Date Modified Username Field Change
2006-01-22 15:32 Trocotronic New Issue
2006-01-23 15:35 syzop Relationship added duplicate of 0002753
2006-01-23 15:39 syzop Relationship deleted 0002753
2006-01-23 15:39 syzop Relationship added related to 0002753
2006-01-23 15:43 syzop Status new => resolved
2006-01-23 15:43 syzop Fixed in Version => 3.2.4
2006-01-23 15:43 syzop Resolution open => fixed
2006-01-23 15:43 syzop Assigned To => syzop
2006-01-23 15:43 syzop Note Added: 0011033
2006-01-23 15:43 syzop Note Edited: 0011033
2006-01-23 19:33 Trocotronic Status resolved => feedback
2006-01-23 19:33 Trocotronic Resolution fixed => reopened
2006-01-23 19:33 Trocotronic Note Added: 0011040
2006-01-23 19:37 syzop Note Added: 0011041
2006-01-23 19:42 syzop Status feedback => resolved
2006-01-23 19:42 syzop Resolution reopened => fixed
2006-01-23 19:42 syzop Note Added: 0011042
2006-01-24 08:18 syzop Relationship added has duplicate 0002768
2006-01-24 08:18 syzop Relationship added has duplicate 0002769