View Issue Details

IDProjectCategoryView StatusLast Update
0002772unrealircdpublic2006-01-26 16:13
ReporterHERZAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSDebianOS Version2.6.13
Product Version3.2.4 
Target VersionFixed in Version3.2.4 
Summary0002772: Nick Collision on Nicks with \ included
DescriptionHi,

strange Bug on Pre1 - Pre2 - and latest Release Candidate 1


Nicknames with nick[letter\letter] got collissions with himself

I have test it on more that 2 Networks , and myself TestServer
RC1.

Just have a look:

[11:48] <@HERZ> [11:48] * You were killed by winxp.cbcgonline.com (winxp!winxp.cbcgonline.com (HERZ[N\A](?) <- bsd.cbcgonline.com))
[11:48] <@HERZ> -
[11:48] <@HERZ> [11:48] Closing Link: HERZ[N\A][dslb-084-060-146-045.pools.arcor-ip.net] winxp.cbcgonline.com (Killed (winxp.cbcgonline.com (HERZ[N\A](?) <- bsd.cbcgonline.com)))

[11:39] -testserver.insiderZ.DE- *** Global -- Nick collision on HERZ[N\A] (matriX.insiderZ.DE 1138271930 <- matriX.insiderZ.DE 1138271959)
-
[11:39] -testserver.insiderZ.DE- *** Global -- Nick collision on DevilDude[N\A] (matriX.insiderZ.DE 1138271867 <- matriX.insiderZ.DE 1138271974)


Steps To ReproduceJust reproduce it:

Go on Network with Nick TestN\A ; join Channel xxx
and type Hello world

You Killed by Server "Nick Collision"
Additional InformationBug Update: (atm. reproducable on Pre1 Pre2 and RC1)

Just /nick Bla\ and a MODE MSG NOTICE SAY on Channel
is enough to produce a Kill:

* Quits: ~test\t (onliner@horrorist.IP6ng.net) (Killed (irc2.IP6ng.net (test\t(?) <- irc.IP6ng.net)))

This kill comes only when 2 Server linked , standalone you got no collision.

When you got Killed on from Server A with collision , on Server B you are
still there as GHOST. /Whois Nick you got a WHOIS Reply , with
/whois Nick Nick a Reply with (no such server).
TagsNo tags attached.
3rd party modules

Activities

syzop

2006-01-26 09:14

administrator   ~0011058

I *think* this is now fixed in CVS, thanks HERZ :P.

I'll leave the bug open until I prepare rc2 (which is soon ;p).

penna

2006-01-26 09:49

reporter   ~0011060

Last edited: 2006-01-26 09:52

I can't reproduce this with 1.1.1.1.2.1.2.1.2.2234.2.403
Tested with test\t and with pen[n\a]
I joined a channel and said something and worked just normal

edit: ok forget it. I just read the changelog and I didn't updated yet to a newer one with the new match() :)

syzop

2006-01-26 09:53

administrator   ~0011061

It got broken in .431 (.431 till .438)

syzop

2006-01-26 16:13

administrator   ~0011068

Should be fixed in rc2.

Issue History

Date Modified Username Field Change
2006-01-26 08:19 HERZ New Issue
2006-01-26 08:28 syzop Status new => confirmed
2006-01-26 09:14 syzop Note Added: 0011058
2006-01-26 09:49 penna Note Added: 0011060
2006-01-26 09:52 penna Note Edited: 0011060
2006-01-26 09:53 syzop Note Added: 0011061
2006-01-26 16:13 syzop Status confirmed => resolved
2006-01-26 16:13 syzop Fixed in Version => 3.2.4
2006-01-26 16:13 syzop Resolution open => fixed
2006-01-26 16:13 syzop Assigned To => syzop
2006-01-26 16:13 syzop Note Added: 0011068