View Issue Details

IDProjectCategoryView StatusLast Update
0002779unrealdocumentationpublic2015-08-08 08:16
ReporterRicardoAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSAllOS VersionAll
Product Version3.2.4 
Target VersionFixed in Version3.4-beta1 
Summary0002779: +o or +O ?
DescriptionToday,

<Ricardo> hello, I want know if the flag(umode) for Global Opers is +o or +O. Some places is said +O, but the umode set at /oper is +o
<Ricardo> at the Docs:
<Ricardo> o local Makes you a local operator
<Ricardo> O global Makes you a global operator

<Special> helpop says the reverse of what the docs do, it seems

<Ricardo> also the /oper message is wrong: -Server- Nick (*@*) [Nick] is now an operator (O)
<Special> terribly inconsistant :o

<aquanight> FLAG o is local
<aquanight> MODE o is global

<aquanight> Special: it's probably a holdover from very old IRCds
<Special> shot.
<aquanight> used to be you used a O:Line to make a global operator and he got umode +o
<aquanight> and o:Line was used to make local operator and he got umode +O

Very confusing is the global/local O:line system...
It would be better if changed or, at least, corrected the docs/helpop.
TagsNo tags attached.
3rd party modules

Relationships

child of 0004157 resolvedtmcarthur config definable oper levels 

Activities

Dukat

2006-01-29 04:26

reporter   ~0011097

The docs and helpop are both correct.

As aquanight said:
FLAG o is local
MODE o is global

A operflag is not a usermode.


Anyway, the solution is very easy: Don't use this old and ugly system, use the new operflags (local, global etc.).


/me votes to remove the old system in 3.3 :-)

Ricardo

2006-01-29 11:02

reporter   ~0011098

My idea is to uniform the umode letter and the flag letter. Even if you use global; in your unrealircd.conf, you will get the "User is using modes +o( plus some other modes)" at IRC.

Because the IRC shows the modes letter I think they won't remove the letter system that is also an easy system to include lot of modes without losing configuration space. But they can standardize one letter for the modes and flags.

w00t

2006-02-06 21:52

reporter   ~0011153

And in 'standardising' unintentionally [and silently] break many existing configurations for a minor or nill gain?

...Yeah.

Dukat, some people prefer such a system - I'm one of them personally, as I hate to type that much out, and dislike seeing ~20 lines just for one oper block.

Ricardo

2006-02-07 11:36

reporter   ~0011159

Last edited: 2006-02-07 18:55

<...break many existing configurations for a minor or nill gain>

Will break something if users upgrade and don't read the Changelog. Every new version always break something even if only modules. This is an update, must break old issues.
[ And why the Mozilla fans think IE should standardize the called Acid2 if no one use it? (I never see any website draw that wasn't a picture but a strange code) (Please note that I'm not a web designer/developer and can be wrong). And IE removing ActiveX will not break too many site configurations? ]

falconkirtaran

2013-05-23 06:00

reporter   ~0017655

What, if anything, needs to be done here?

nenolod

2013-05-23 09:49

reporter   ~0017657

Remove support for the old letter-based oper flags system, and probably also the m_svso stuff.

This should be done at the same time as moving to privilege sets / IAPCM as has been done by charybdis, inspircd, etcetera already.

katsklaw

2013-05-29 14:33

reporter   ~0017696

I disagree with the "acknowledged" status of this bug. IMVHO it should be closed as an invalid bug as it is no bug at all from 3.2.10.1 and back. helpops and docs are correct, the reporter was confusing oper flags with umodes as stated.

IF we choose to rid the old flags and I don't see why we should even if 0004157 comes to pass because flags "ABCxyz"; is far easier to type than a multi-lined flags sub-block and no more difficult to understand.

To prevent confusion change the oper flags to match the umode case.

syzop

2015-08-08 08:15

administrator   ~0018573

locop (+O) no longer exists, so fixed now.

Issue History

Date Modified Username Field Change
2006-01-28 20:01 Ricardo New Issue
2006-01-29 04:26 Dukat Note Added: 0011097
2006-01-29 11:02 Ricardo Note Added: 0011098
2006-02-06 21:52 w00t Note Added: 0011153
2006-02-07 11:36 Ricardo Note Added: 0011159
2006-02-07 18:55 Ricardo Note Edited: 0011159
2007-04-27 03:41 stskeeps Status new => acknowledged
2013-05-23 06:00 falconkirtaran Note Added: 0017655
2013-05-23 09:49 nenolod Note Added: 0017657
2013-05-23 09:50 nenolod Relationship added child of 0004157
2013-05-29 14:33 katsklaw Note Added: 0017696
2014-03-14 01:14 peterkingalexander Issue cloned: 0004303
2015-08-08 08:15 syzop Note Added: 0018573
2015-08-08 08:15 syzop Status acknowledged => resolved
2015-08-08 08:15 syzop Fixed in Version => 3.4-beta1
2015-08-08 08:15 syzop Resolution open => fixed
2015-08-08 08:15 syzop Assigned To => syzop