View Issue Details

IDProjectCategoryView StatusLast Update
0002797unrealircdpublic2006-02-05 13:28
ReportertabrisnetAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux/x86OSDebian LinuxOS Versiontesting
Product Version3.2.4 
Target VersionFixed in Version3.2.4 
Summary0002797: Globbing/Wildcard error in oper::from::userhost
Descriptionit seems that ? doesn't work properly in oper::from::userhost anymore. At least not for IP addresses.

userhost *@12.2??.*; <-- doesn't work anymore, did in 3.2.3
userhost *@12.20?.*; <-- doesn't work anymore, did in 3.2.3
userhost *@12.206.*; <-- works fine, but I need wider.
Steps To Reproducecreate a oper block with ? in the userhost.
Additional InformationProbably related to the new wildcard/globbing code in 3.2.4
TagsNo tags attached.
3rd party modules

Activities

syzop

2006-02-05 12:00

administrator   ~0011143

hmm... that's not a good sign :P

syzop

2006-02-05 12:07

administrator   ~0011144

Looks like the '?' wildcard is completely broken in 3.2.4

syzop

2006-02-05 13:28

administrator   ~0011145

Fixed in CVS / reuploading release files :p.

Issue History

Date Modified Username Field Change
2006-02-05 01:45 tabrisnet New Issue
2006-02-05 12:00 syzop Note Added: 0011143
2006-02-05 12:00 syzop Status new => confirmed
2006-02-05 12:07 syzop Note Added: 0011144
2006-02-05 13:28 syzop Status confirmed => resolved
2006-02-05 13:28 syzop Fixed in Version => 3.2.4
2006-02-05 13:28 syzop Resolution open => fixed
2006-02-05 13:28 syzop Assigned To => syzop
2006-02-05 13:28 syzop Note Added: 0011145