View Issue Details

IDProjectCategoryView StatusLast Update
0002802unrealircdpublic2006-09-23 07:07
ReporterRomeoAssigned Tosyzop 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSWindows Server 2003 ServicePack1OS Version5.2.3790
Product Version3.2.4 
Target VersionFixed in Version3.2.6 
Summary0002802: UnrealIRCd crashes on startup (or fails to work) under Windows Server 2003 Service Pack 1
DescriptionBoth SSL- and non-SSL versions are crashed.

Log files for version, installed from Unreal3.2.4.exe (1,900,080 bytes):

service.log file
----------------

* Loading IRCd configuration ..
* Configuration loaded without any problems ..
UnrealIRCd has encountered a fatal error. Debugging information has been dumped to wircd.1596.core, please email this file to coders@lists.unrealircd.org.

wircd.1596.core file
--------------------

Generated at Mon Feb 06 13:44:23 2006

Windows Server 2003 Service Pack 1 (5.2.3790)
Unreal3.2.4[FinWXOoZE] (1.1.1.1.2.1.2.1.2.2234.2.454 2006/02/05 17:43:19)
-----------------
Memory Information:
    Physical: (Available:808MB/Total:1023MB)
    Virtual: (Available:2014MB/Total:2047MB)
-----------------
Exception:
    Access Violation
-----------------
Backup Buffer:
    
-----------------
Registers:
    EAX=0x00f4ff2c EBX=0x00d47680 ECX=0x00f5ff4c
    EDX=0x00000000 ESI=0x00d45640 EDI=0x00000000
    EIP=0x00462dc6 EBP=0x00000000 ESP=0x00f3feac
-----------------
Stack Trace:
    Module: wircd
        #0 (null):0: ares_fds
Steps To ReproduceInstall Unreal3.2.4.exe or Unreal3.2.4-SSL.exe under Windows Server 2003 Service Pack 1, and try to start it.
Additional InformationUnder other Windows versions (Windows 2000 Service Pack 4, Windows XP Service Pack 2) it works without any problems.
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0003029 resolvedsyzop [error] resolver: ares_init_options() failed with error code -1 [(null)] 
child of 0002936 resolvedsyzop 3.2.6 Release 

Activities

syzop

2006-02-09 14:05

administrator   ~0011186

Hmm.. I think I would need a 2003 box myself to be able to figure this out...

Stealth

2006-02-09 15:39

reporter   ~0011188

If I can remember next time I am at school, I'll boot my 2k3 server and try it out

syzop

2006-02-13 11:14

administrator   ~0011220

Last edited: 2006-02-13 11:16

I was able to test unreal on "windows 2003 R2 standard edition service pack 1" today, and it didn't crash here...

EDIT: Just FYI I tried it both in GUI and services mode.

Romeo

2006-02-13 12:43

reporter   ~0011222

I'm using Windows Server 2003 Enterprise Edition SP1, with last hotfixes from Microsoft (Windows Update), localized Russian version. Unreal 3.2.4 crashed :( Unreal 3.2.3 works fine.

Very strange problem.

syzop

2006-02-13 13:17

administrator   ~0011223

Maybe the 'R2' thing fixed it? I've no idea, I only got that machine not one without R2 (whatever it is..).

Bugz, if you got some time, could you try to run Unreal on 2003? See if it crashes (when someone connects etc) :)

Stealth

2006-02-13 22:45

reporter   ~0011229

Mine seems to start on Windows 2003 Standard with all updates installed. I used the most basic configuation, and no problems at all. My 2k3 has all the Windows Updates installed. Is it possible to attach a conf to this so I can have an idea on what is set? (feel free to bleep passwords and cloak keys)

Romeo

2006-02-14 11:52

reporter   ~0011237

Last edited: 2006-02-14 13:46

Ok,
I'll try to do it tomorrow. (I have no access to my server now).

2006-02-15 11:11

 

ircderr.zip (28,255 bytes)

Romeo

2006-02-15 11:12

reporter   ~0011240

I suppose that the problem appears only with ENTERPRISE EDITION of Windows Server 2003. It's possible that with STANDARD EDITION there is no problem.

IRCd cannot start on any computer under this OS installed with any modification of unrealircd.conf, error is the same in all cases. Error appears under "cleanly installed" OS without any updates and service packs as well as under OS with SP1 and updates.

===
Steps of my "clean" experiment:

1. Install Windows Server 2003 Enterprise ("clean install", booting from installation CD, with creating and formatting new HDD partition).
 
2. Copy msvcr70.dll (344,064 bytes) into Windows\System32 directory.

3. Run Unreal3.2.4.exe (1,900,080 bytes) and install IRCd.

4. Copy Unreal3.2\doc\example.conf to Unreal3.2\unrealircd.conf.

5. Modify this file (only most important sections and parameters, file is in attached archive ircderr.zip).

6. Start IRCd. Result is ErrorScreen.png (in attached archive ircderr.zip).
===

What's wrong in my actions? :(

Maybe some Windows configuration settings can affect this?

Can you try to run UnrealIRCd 3.2.4 under ENTERPRISE EDITION of Windows Server 2003, not STANDARD EDITION?

syzop

2006-02-15 11:29

administrator   ~0011241

I'll test again on standard when I can (though I think it will just fine).

I don't know anyone (irl) with enterprise edition, so no.. I cannot test it on that.
I was also not planning to buy it myself, seeing it costs $5000 USD ;).

Romeo

2006-02-15 14:12

reporter   ~0011242

Unfortunately, our company have only Enterprise Edition of 2003 Server...
Now I have to use Unreal 3.2.3
it is a pity

Romeo

2006-02-16 11:06

reporter   ~0011248

Some more information about my trouble.

I suppose that problem is in resolver_channel pointer which must be initialized by function

   ares_init_options(&resolver_channel, &options, ARES_OPT_TIMEOUT|ARES_OPT_TRIES|ARES_OPT_FLAGS);

(file res.c line 90), but I see that after this call resolver_channel==NULL! After that, during executing of function

   ares_fds(resolver_channel, &read_set, &write_set);

(file s_bsd.c line 1753) IRCd causes exception "Read access violation", probably, because of a NULL pointer.

Can you explore the behavior of ares_init_options() function thoroughly? In which case it can return resolver_channel==NULL? Incorrect work of malloc() function ("channel = malloc(sizeof(struct ares_channeldata));" at ine 96 of areas_init.c file), or maybe another reason?

syzop

2006-02-16 11:14

administrator   ~0011249

Ok.

Did you try running in GUI mode btw? Might as well try that to see if it helps.

Romeo

2006-02-16 11:42

reporter   ~0011250

My steps were:

1. Remove "add_remote_include", "find_loaded_remote_include", "find_remote_include" and "find_remote_include" from wircd.def file to avoid linker errors "unresolved external" in "Simple compile" mode (no SSL/ZIP/Remote includes).

2. Build IRCd with DEBUG=1 executing "nmake -f makefile.win32" (Visual Studio .NET 2003).

3. Load WIRCD.exe into OllyDBG Debugger (http://www.ollydbg.de/). (There was a difficulty with using native VC .NET IDE to debug because your sources haven't IDE project, only makefile).

4. Trace executing of WIRCD step-by-step in View Source mode.

vonitsanet

2006-02-19 13:34

reporter   ~0011270

I'll have a 2003 enterprise system here at the end of the next week.
If u need my help...

syzop

2006-02-19 13:52

administrator   ~0011271

Last edited: 2006-02-19 14:00

Sounds good ;).

Your first test should be to try to run Unreal 3.2.4 on it (just the one from unrealircd.com), see if it crashes. (Just to say; try that first, no compiling/etc needed, only if it turns out it really crashes at you too then compiling stuff etc would be needed).

Thanks ;).

Romeo

2006-02-20 11:50

reporter   ~0011272

Last edited: 2006-02-20 11:52

2syzop:

Today I have explored the return code of ares_init_options() function on my Enterprise Edition of 2003 server. So, after executing of

int ret_code;
ret_code = ares_init_options(&resolver_channel, &options, ARES_OPT_TIMEOUT|ARES_OPT_TRIES|ARES_OPT_FLAGS);

I see that ret_code == -1 (instead of ARES_SUCCESS or 0).

2vonitsanet: thank you for wish to help.

syzop

2006-02-20 12:54

administrator   ~0011273

Btw, there's slightly improved error reporting in CVS (basically it should report some kind of error instead of crash). So if you are bored you could checkout latest CVS and see what you get (unreal3_2_fixes branch).

Romeo

2006-02-26 11:18

reporter   ~0011304

CVS (25.02.2006), VC .NET 2003, command "nmake -f makefile.win32":

=============================
wircd.def : error LNK2001: unresolved external symbol add_remote_include
wircd.def : error LNK2001: unresolved external symbol find_loaded_remote_include
wircd.def : error LNK2001: unresolved external symbol find_remote_include
wircd.def : error LNK2001: unresolved external symbol remote_include
wircd.lib : fatal error LNK1120: 4 unresolved externals
LINK : fatal error LNK1141: failure during build of exports file
NMAKE : fatal error U1077: 'link' : return code '0x475'
Stop.
=============================

After removing add_remote_include, find_loaded_remote_include, find_remote_include and remote_include from wircd.def file:

=============================
M_PASS.obj : error LNK2019: unresolved external symbol _Find_cgiirc referenced in function _m_webirc
src/modules/commands.dll : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.
=============================

What's wrong?

syzop

2006-02-26 11:22

administrator   ~0011305

Follow the instructions from the faqitem ( http://www.vulnscan.org/UnrealIRCd/faq/76 ) instead of trying to edit the wircd.def manually ;p.

syzop

2006-02-26 11:28

administrator   ~0011306

Current CVS compiled (was planning to put a win cvs build online anyway):
http://www.syz.dds.nl/Unreal3.2.4-cvs20060226.exe

Romeo

2006-02-26 13:39

reporter   ~0011307

Thanks.
I'll try to run it tomorrow :)

Romeo

2006-02-27 11:25

reporter   ~0011309

Last edited: 2006-02-27 14:07

Unreal3.2.4-cvs20060226.exe cannot start on my Enterprise Edition 2003 Server with the same error (but it is not crash, it's configuration error window):

====================================================
Configuration Error
====================================================

* Loading IRCd configuration ..
* Configuration loaded without any problems ..
[error] resolver: ares_init_options() failed with error code -1 [(null)]

                               [OK]
====================================================

Romeo

2006-03-07 11:50

reporter   ~0011343

ADDITION: When I try to run 3.2.4 under Windows Server 2003 Enterprise installed from other distribution CD, other version (english, non-localized), error is the same. Therefore, problem is not in Windows distribution... problem is in 2003 Enterprise Edition, independently of localization.

vonitsanet

2006-03-16 06:33

reporter   ~0011386

Last edited: 2006-03-16 06:33

I have installed unreal3.2.4 on windows 2003 enterprise and it runs just fine...

EDIT: windows 2003 enterprise with service pack 1

syzop

2006-03-25 13:39

administrator   ~0011434

vonitsanet: ok thanks :P

I got another report of a windows 2003 crash a few days ago... So I guess Romeo is not the only one.

syzop

2006-04-06 16:37

administrator   ~0011478

Hmm Romeo, are you sure your architecture is i386 and not amd64/whatever?
In other words, you are not using a 64 bit architecture but really 32 bits?

Because if you would be using 64 bits, then maybe we got the source of the problem there.. It would explain why it works at some with the exact same windows version, while not at you + a few others :P.

HDR123

2006-04-06 16:57

reporter   ~0011479

Last edited: 2006-04-06 16:57

I'm having the same problem. http://forums.unrealircd.com/viewtopic.php?t=3209

I'm running Windows Server 2003 SP1 x64 R2 Enterprise on an AMD Opteron 165 with 2GB RAM.

syzop

2006-04-07 06:22

administrator   ~0011485

hm k, another guy said he was using a 32 bits proc and also has this problem, so I guess this isn't much related to 64 bit after all...

Just in case anyone wonders what the status of me on this is.. well.. nothing.. there's (nearly) nothing I can do, I cannot reproduce the problem here so I can debug.. it works perfectly fine (unfortunately).. additionally, the bug itself is in the c-ares libary, and I don't see why it would ever really return something like this.
Now thinking of it, I can only think of adding like XX debug statements in c-ares, compile everything, and send it to one of you guys, to make it print out where it actually failed (and where it passed)... Of course that's not exactly the best debugging scenario, but I don't see any other options.. ;)

Romeo

2006-04-07 13:13

reporter   ~0011486

2syzop: I am using 32-bit i386, not x64.

Robur

2006-04-24 21:05

reporter   ~0011606

It works fine on my w2k3 server Enterprise edition
For some reasons, i reinstall Windows from different distributive (Windows 2003 server Enterprise Edition Service Pack 1 RUS, on same mashine, and it crashes.

Xuefer

2006-04-25 20:43

reporter   ~0011608

i'm not sure what's on with your win2k3sp1, but FYI: when i'm trying to skipping the message loop by "return xx;", it crashed inside ares. i guess the ares threads isn't terminated correctly if there's any bailout before message loop.

Bock

2006-05-29 19:32

reporter   ~0011794

Stack Trace:
    Module: wircd
        #0 (null):0: ares_fds


It's write to wircd.*

In CHANGES of c-ares 1.3.1-cvs:
* December 22

- Daniel Stenberg added ares_getsock() that extracts the set of sockets to
  wait for action on. Similar to ares_fds() but not restricted to using
  select() for the waiting.

Maybe if take and compile with c-ares from cvs UnrealIRCd don't crash?
I try to compile, but I'm not programmer and c-ares from cvs didn't compile.

syzop

2006-05-30 06:03

administrator   ~0011796

Last edited: 2006-05-30 06:26

To my knowledge, that has nothing to do with this crash (unfortunately :P), basically it's just another interface to ares so you can use poll/whatever instead of select.

Oh, and, btw, the crash in ares_fds() happened because we forgot to check failure of initalization of the resolver, now it doesn't even reach ares_fds() anymore ;). So.. the bug is somewhere in the init code (of c-ares).

Bock

2006-06-17 17:39

reporter   ~0011975

* Configuration loaded without any problems ..
[error] resolver: ares_init_options() failed with error code -1 [(null)]

:-\ didn't create *core files, but in status window write it.

Romeo

2006-07-19 07:02

reporter   ~0012076

Unfortunately, 3.2.5 also can't start in my 2003 Server Enterprise (Win32) because of ares_init_options() failure.

Maybe, some information about this error is already available from c-ares's developers?

Bock

2006-08-14 17:51

reporter   ~0012179

c-ares developerts don't have windows wolontuers for testing windows part of c-ares.

Bock

2006-08-29 16:54

reporter   ~0012263

o_O
One man suggest the next solution:
property of wircd.exe, Compatibility, Compatibility mode - windows XP.
After what he sad, that unreal start on win2003 SP1.

Bock

2006-09-03 07:06

reporter   ~0012294

Today I find strange thing. One of servers don't want start (win2003sp1). Connecting to hub going throw ISP connection don't requiring vpn-connection. I ask to make internet connection and see my eyes what happened on server.
After creating vpn-connection Unreal loading without troubles o_O.

And I ask to show me ipconfig /all. I've be shocked.
[14:43:25] [Analyzer`]: Connection-specific DNS Suffix . :
[14:43:25] [Analyzer`]: Description . . . . . . . . . . . : Intel(R) PRO/100 Network Connection
[14:43:25] [Analyzer`]: Physical Address. . . . . . . . . : 00-50-8B-6A-E3-18
[14:43:25] [Analyzer`]: DHCP Enabled. . . . . . . . . . . : No
[14:43:25] [Analyzer`]: IP Address. . . . . . . . . . . . : 10.16.192.1
[14:43:25] [Analyzer`]: Subnet Mask . . . . . . . . . . . : 255.255.192.0
[14:43:25] [Analyzer`]: Default Gateway . . . . . . . . . :

Server without DGW and DNS. o_O
After establish vpn-session add next params:
[14:44:01] [Analyzer`]: PP adapter Solo-VPN:
[14:44:01] [Analyzer`]: Connection-specific DNS Suffix . :
[14:44:01] [Analyzer`]: Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
[14:44:01] [Analyzer`]: Physical Address. . . . . . . . . : 00-53-45-00-00-00
[14:44:01] [Analyzer`]: DHCP Enabled. . . . . . . . . . . : No
[14:44:01] [Analyzer`]: IP Address. . . . . . . . . . . . : 195.222.80.211
[14:44:01] [Analyzer`]: Subnet Mask . . . . . . . . . . . : 255.255.255.255
[14:44:01] [Analyzer`]: Default Gateway . . . . . . . . . : 0.0.0.0
[14:44:01] [Analyzer`]: DNS Servers . . . . . . . . . . . : 195.222.64.67
[14:44:01] [Analyzer`]: 195.222.70.10

And, I think, c_ares can do ares_init_options()... And Unreal is up!

After this I ask Analyzer` add to settings of Ethernet card DNS servers of ISP and server start without vpn-connection.

2 Romeo:
Into your server do you correct dns settings on network card?

On one side c_ares is responsible for dns and as for the error return "[error] resolver: ares_init_options() failed with error code -1 [(null)] " they are right when they do it like that. On the other side unreal must start then without dns resolving but with settings from unrealircd.conf taken.

I see 2 ways from this:
1) Ask about it developers c_ares.
2) See the code for startup unreal without resolvind dns.

And, most important, learn admins of ircd to correct settings of server :]

stskeeps

2006-09-03 07:16

reporter   ~0012295

And to rephrase things a bit, Ares crashes/doesn't want to start when there is no DNS servers on any on the network connections.

Romeo

2006-09-03 07:32

reporter   ~0012296

Hmm, it's a very interesting information for me...

My server works in local area network, which have no any connection with Internet. All computers (including server) have local IP addresses like 192.168.1.x and DNS is NOT used (but DNS Service is running in automatic mode). It's very simple network. Also, DNS resolving is DISABLED in unrealircd.conf.

What can I try to do? Tell me please in details.

Bock

2006-09-03 08:22

reporter   ~0012297

Network Connections - Local Area Connection.
General - properties. Internet Protocol (TCP/IP).
Use the following DNS server adresses:
Just try to add 127.0.0.1.
The best way - setup DNS server.
Add or remove programms - Add\Remove Windows Components - Networking services.
Choose Domain Name System (DNS). Install and configure it.

Romeo

2006-09-03 08:43

reporter   ~0012298

Ok, thank you, I'll try to do it...

Romeo

2006-09-05 10:01

reporter   ~0012320

YES!!! YES!!! YES!!! :)

There's NO more problem!

After specifying DNS Server address 127.0.0.1 in TCP/IP Properties of network connection in Windows Server 2003 (this field was empty earlier), Unreal starts and works fine!

Great thanks to Bock!

syzop

2006-09-05 11:07

administrator   ~0012327

related: http://curl.haxx.se/mail/lib-2006-06/0137.html

syzop

2006-09-05 11:09

administrator   ~0012328

Perhaps not too important anymore, but.. it makes me curious.

Is this a specific problem to windows 2003? Or does windows 2003 have some weird option (DNS automatic mode ??) that makes more users configure their servers without DNS or something. Or does XP/etc somehow do certain things and always have a DNS server, like a fallback to 127.0.0.1.

Bock: Are you still thinking running in windows XP compatability mode fixes this? (so even if no DNS server present). Or are there even 2 bugs? :P

Romeo

2006-09-05 11:33

reporter   ~0012331

2syzop: it's possible that this a specific problem to Windows Server 2003 Enterprise... because of there's no problem in Windows XP, WITHOUT specifying of a DNS Server address in connection properties.

syzop

2006-09-05 11:36

administrator   ~0012332

ok, thanks :p. interesting.

I'll make it fallback to set::dns::nameserver if initalization fails.

Bock

2006-09-05 12:47

reporter   ~0012333

Last edited: 2006-09-05 12:48

syzop:"Bock: Are you still thinking running in windows XP compatability mode fixes this? (so even if no DNS server present). Or are there even 2 bugs? :P"
No, not 2 bugs. I ask man, he don't remember settings of server. :] I think that he forgot add DNS servers to setting of LAN.
It's specific trouble of 2003, cos I ask people to remove their DNS settings on WinXP SP2 and try to start Unreal. It run.

Bock

2006-09-11 16:35

reporter   ~0012379

Last edited: 2006-09-15 14:22

http://daniel.haxx.se/projects/c-ares/mail/c-ares-archive-2006-09/0000.shtml

Maybe it fix bug?
EDIT: No, I just try to compile with this patch and got error...

syzop

2006-09-19 08:45

administrator   ~0012407

Fixed in 32* (.564):
- Windows 2003: Fixed UnrealIRCd unable to boot if no DNS server is configured, we now
  fallback to set::dns::nameserver in such a case. Thanks to Romeo (reporter, 0002802)
  and Bock for tracing this down.

I've uploaded a new win cvs version at http://www.vulnscan.org/wincvs which includes this fix. If someone could confirm that fixes it on a DNS-less machine, that would be helpful. I'll leave the bug open until someone confirmed.

Bock

2006-09-23 07:01

reporter   ~0012417

[Sat Sep 23 14:55:18 2006] - [warning] Unable to get DNS server from registry. Using the one from set::dns::nameserver (127.0.0.1) instead
[Sat Sep 23 14:55:18 2006] - TIME SYNCH: Unable to synchronize time: Timeout. This happens sometimes, no error on your part.


I think, this bug we can close :]]

syzop

2006-09-23 07:07

administrator   ~0012418

Ok, thanks.

As mentioned, was fixed in 32*. Now also fixed in 33*.

Issue History

Date Modified Username Field Change
2006-02-06 12:26 Romeo New Issue
2006-02-09 14:05 syzop Note Added: 0011186
2006-02-09 15:39 Stealth Note Added: 0011188
2006-02-13 11:14 syzop Note Added: 0011220
2006-02-13 11:16 syzop Note Edited: 0011220
2006-02-13 12:43 Romeo Note Added: 0011222
2006-02-13 13:17 syzop Note Added: 0011223
2006-02-13 22:45 Stealth Note Added: 0011229
2006-02-14 11:52 Romeo Note Added: 0011237
2006-02-14 13:46 Romeo Note Edited: 0011237
2006-02-15 11:11 Romeo File Added: ircderr.zip
2006-02-15 11:12 Romeo Note Added: 0011240
2006-02-15 11:29 syzop Note Added: 0011241
2006-02-15 14:12 Romeo Note Added: 0011242
2006-02-16 11:06 Romeo Note Added: 0011248
2006-02-16 11:14 syzop Note Added: 0011249
2006-02-16 11:42 Romeo Note Added: 0011250
2006-02-19 13:34 vonitsanet Note Added: 0011270
2006-02-19 13:52 syzop Note Added: 0011271
2006-02-19 14:00 syzop Note Edited: 0011271
2006-02-20 11:50 Romeo Note Added: 0011272
2006-02-20 11:52 Romeo Note Edited: 0011272
2006-02-20 12:54 syzop Note Added: 0011273
2006-02-26 11:18 Romeo Note Added: 0011304
2006-02-26 11:22 syzop Note Added: 0011305
2006-02-26 11:28 syzop Note Added: 0011306
2006-02-26 13:39 Romeo Note Added: 0011307
2006-02-27 11:25 Romeo Note Added: 0011309
2006-02-27 14:07 Romeo Note Edited: 0011309
2006-03-07 11:50 Romeo Note Added: 0011343
2006-03-16 06:33 vonitsanet Note Added: 0011386
2006-03-16 06:33 vonitsanet Note Edited: 0011386
2006-03-25 13:39 syzop Note Added: 0011434
2006-04-06 16:37 syzop Note Added: 0011478
2006-04-06 16:57 HDR123 Note Added: 0011479
2006-04-06 16:57 HDR123 Note Edited: 0011479
2006-04-07 06:22 syzop Note Added: 0011485
2006-04-07 13:13 Romeo Note Added: 0011486
2006-04-24 21:05 Robur Note Added: 0011606
2006-04-25 20:43 Xuefer Note Added: 0011608
2006-05-29 19:32 Bock Note Added: 0011794
2006-05-30 06:03 syzop Note Added: 0011796
2006-05-30 06:26 syzop Note Edited: 0011796
2006-05-31 07:24 syzop Relationship added child of 0002936
2006-06-17 17:39 Bock Note Added: 0011975
2006-07-19 07:02 Romeo Note Added: 0012076
2006-08-13 13:59 syzop Summary UnrealIRCd 3.2.4 crashes on startup under Windows Server 2003 Service Pack 1 => UnrealIRCd crashes on startup (or fails to work) under Windows Server 2003 Service Pack 1
2006-08-14 17:51 Bock Note Added: 0012179
2006-08-20 06:35 syzop Relationship added has duplicate 0003029
2006-08-29 16:54 Bock Note Added: 0012263
2006-09-03 07:06 Bock Note Added: 0012294
2006-09-03 07:16 stskeeps Note Added: 0012295
2006-09-03 07:32 Romeo Note Added: 0012296
2006-09-03 08:22 Bock Note Added: 0012297
2006-09-03 08:43 Romeo Note Added: 0012298
2006-09-05 10:01 Romeo Note Added: 0012320
2006-09-05 11:07 syzop Note Added: 0012327
2006-09-05 11:09 syzop Note Added: 0012328
2006-09-05 11:10 syzop Status new => assigned
2006-09-05 11:10 syzop Assigned To => syzop
2006-09-05 11:33 Romeo Note Added: 0012331
2006-09-05 11:36 syzop Note Added: 0012332
2006-09-05 12:47 Bock Note Added: 0012333
2006-09-05 12:48 Bock Note Edited: 0012333
2006-09-11 16:35 Bock Note Added: 0012379
2006-09-15 14:22 Bock Note Edited: 0012379
2006-09-19 08:45 syzop Note Added: 0012407
2006-09-23 07:01 Bock Note Added: 0012417
2006-09-23 07:07 syzop Status assigned => resolved
2006-09-23 07:07 syzop Fixed in Version => 3.2.6
2006-09-23 07:07 syzop Resolution open => fixed
2006-09-23 07:07 syzop Note Added: 0012418