View Issue Details

IDProjectCategoryView StatusLast Update
0002853unrealircdpublic2006-04-09 13:41
ReporterrscAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi686OSLinuxOS Version2.6.x
Product Version3.2.4 
Target VersionFixed in Version3.2.5 
Summary0002853: RPL_MYPORTIS is at ircd startup spoofed to syslogd
DescriptionCopy & paste from my irc log should be enough to get the problem:

[19:30:34] <+rsc> ehm...why is UnrealIRCd 3.2.4 spoofing RPL_MYPORTIS to syslogd?
[19:30:54] <+rsc> Maybe I should say, this is done while starting the ircd
[19:31:02] <@Stskeeps> rsc: i'd say ghosts in the shell.. but sec
[19:31:08] <@Stskeeps> but yes, i know that thing
[19:31:16] <+rsc> what's the fix?
[19:31:20] <+rsc> or a workaround? ;)
[19:32:29] <@Stskeeps> #ifndef _WIN32
[19:32:29] <@Stskeeps> if (cptr == &me) /* KLUDGE to get it work... */
[19:32:29] <@Stskeeps> {
[19:32:29] <@Stskeeps> char buf[1024];
[19:32:29] <@Stskeeps> (void)ircsprintf(buf, rpl_str(RPL_MYPORTIS), me.name, "*",
[19:32:32] <@Stskeeps> ntohs(server.SIN_PORT));
[19:32:34] <@Stskeeps> (void)write(0, buf, strlen(buf));
[19:32:35] <@Stskeeps> }
[19:32:37] <@Stskeeps> #endif
[19:32:38] <@Stskeeps> find in s_bsd.c
[19:32:40] <@Stskeeps> remove
[19:32:41] <@Stskeeps> add a bug report
[19:32:45] <@Stskeeps> we have no use for it, imho
[19:32:56] <+rsc> really? Because every ircd seems to keep this code
[19:33:01] <@Stskeeps> well
[19:33:02] <+rsc> including ircnet ircd
[19:33:04] <@Stskeeps> tell me a sane use of it? :P
[19:33:10] <@Stskeeps> it used to be good for some stuff
[19:33:17] <+rsc> your are the c god :)
[19:33:19] <@Stskeeps> but not the way ircds are fun nowadays
[19:33:24] <@Stskeeps> fun = run
[19:33:25] <@Stskeeps> ...
[19:40:49] <+rsc> Stskeeps: works, thanks. I wasn't sure, whether it could break anything else
[19:43:04] <@Stskeeps> hehe
[19:43:17] <@Stskeeps> i dunno wtf the use is anyway :) i've only seen it in debug mode usually
[19:43:33] <@Stskeeps> added bug report?
[19:45:31] <+rsc> no. I just hacked out fprintfs and config_status' to get a quiet startup of unreal, that's enough for me...
[19:45:37] <@Stskeeps> hehe
[19:45:47] <+rsc> but I'll do it now to make you also happy
[19:45:50] <@Stskeeps> k
[19:46:00] <@Stskeeps> not that it actually matters for me, but it might cause other shit ;)
[19:46:06] <@Stskeeps> since im u4 coder now
TagsNo tags attached.
3rd party modules

Relationships

child of 0002748 closedsyzop 3.2.5 Release 

Activities

syzop

2006-03-20 13:44

administrator   ~0011401

roger that :P

syzop

2006-04-09 13:41

administrator   ~0011495

Fixed in CVS [.481]

Issue History

Date Modified Username Field Change
2006-03-16 12:54 rsc New Issue
2006-03-20 13:44 syzop Note Added: 0011401
2006-03-20 13:44 syzop Status new => acknowledged
2006-04-02 16:48 syzop Relationship added child of 0002748
2006-04-09 13:41 syzop Status acknowledged => resolved
2006-04-09 13:41 syzop Fixed in Version => 3.2.5
2006-04-09 13:41 syzop Resolution open => fixed
2006-04-09 13:41 syzop Assigned To => syzop
2006-04-09 13:41 syzop Note Added: 0011495