View Issue Details

IDProjectCategoryView StatusLast Update
0002870unrealircdpublic2015-07-29 10:52
ReporterRon2KAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSAllOS VersionN/A
Product Version3.2.5 
Target VersionFixed in Version3.4-beta3 
Summary0002870: [Feature Request] CIDR for channel bans/exempts/invites
DescriptionIs there any way that CIDR support in UnrealIRCd be expanded to include channel bans, exempts and invites? (For example, /mode #channel +b *!*@192.168.1.0/24 would place a ban in #channel on all IPs from 192.168.1.0 to 192.168.1.255)
TagsNo tags attached.
3rd party modules

Activities

Seaniboy

2006-03-31 06:46

reporter   ~0011458

Would be nice if that would be possible for network/server bans too..

Ron2K

2006-03-31 12:08

reporter   ~0011459

It's already possible for glines etc, if that's what you're asking.

Seaniboy

2006-03-31 13:25

reporter   ~0011461

Hm ok, tried that and it works..
Didn't know that, sorry!

vonitsanet

2006-04-01 10:08

reporter   ~0011463

It's planned for channel bans etc (i think) but if i remember well it was added only for network bans for testing first because it's a new feature.

syzop

2006-04-02 16:41

administrator   ~0011465

Right.
Additionally, because almost all networks use cloaked ips (+x by default), it's also not top-priority.

But yes, this will be implemented eventually :).

syzop

2015-07-29 10:51

administrator   ~0018571

https://github.com/unrealircd/unrealircd/commit/709c7e890ea99e3a8cdca71a5df1831be7bb3f80

commit 709c7e890ea99e3a8cdca71a5df1831be7bb3f80
Author: Bram Matthys <syzop@vulnscan.org>
Date: Tue Jul 28 13:39:56 2015 +0200

    Use match_user() for is banned checking. This also makes CIDR work in bans/exempt/invex.
    Remove ban_realhost, ban_virthost, ban_cloakhost and ban_ip stuff. Should be just as fast if you use match_user() now.

Issue History

Date Modified Username Field Change
2006-03-30 11:58 Ron2K New Issue
2006-03-31 06:46 Seaniboy Note Added: 0011458
2006-03-31 12:08 Ron2K Note Added: 0011459
2006-03-31 13:25 Seaniboy Note Added: 0011461
2006-04-01 10:08 vonitsanet Note Added: 0011463
2006-04-02 16:41 syzop Note Added: 0011465
2007-04-27 03:39 stskeeps Status new => acknowledged
2015-07-29 10:51 syzop Note Added: 0018571
2015-07-29 10:51 syzop Status acknowledged => resolved
2015-07-29 10:51 syzop Fixed in Version => 3.4-beta3
2015-07-29 10:51 syzop Resolution open => fixed
2015-07-29 10:51 syzop Assigned To => syzop